summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2018-08-13 11:00:57 +0800
committerUniversebenzene2018-08-13 11:00:57 +0800
commitc8bc26398962eb9823cbcd728489294b3d4b742c (patch)
treeb3bab2cca5f056b807adcd2c12dc10beae9b73eb
parent23320ffc2a3ea14885d51aaa1257c8a32b0abbea (diff)
downloadaur-c8bc26398962eb9823cbcd728489294b3d4b742c.tar.gz
Bump to new python version
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d95ac0941d7c..3d141a391314 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
# Generated by mksrcinfo v8
-# Fri Jul 13 16:50:14 UTC 2018
+# Mon Aug 13 03:00:27 UTC 2018
pkgbase = python-spherical_geometry
pkgdesc = Python based tools for spherical geometry
pkgver = 1.2.5
- pkgrel = 1
+ pkgrel = 2
url = http://www.stsci.edu/resources/software_hardware/stsci_python
arch = i686
arch = x86_64
license = BSD
- checkdepends = python-pytest-astropy
makedepends = cython
makedepends = qd>=2.3.7
makedepends = python-astropy>=3.0
@@ -26,6 +25,7 @@ pkgname = python-spherical_geometry
depends = qd>=2.3.7
depends = python-astropy>=0.3
optdepends = python-spherical_geometry-doc: Documentation for Spherical Geometry Toolkit
+ optdepends = python-pytest-astropy: For testing suite
pkgname = python-spherical_geometry-doc
pkgdesc = Documentation for Python Spherical Geometry Toolkit
diff --git a/PKGBUILD b/PKGBUILD
index 27e2459ed92e..c723d113de9b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgbase=python-spherical_geometry
pkgname=('python-spherical_geometry' 'python-spherical_geometry-doc')
pkgver=1.2.5
-pkgrel=1
+pkgrel=2
pkgdesc="Python based tools for spherical geometry"
arch=('i686' 'x86_64')
url="http://www.stsci.edu/resources/software_hardware/stsci_python"
license=('BSD')
makedepends=('cython' 'qd>=2.3.7' 'python-astropy>=3.0' 'python-astropy-helpers' 'python-sphinx' 'python-matplotlib')
-checkdepends=('python-pytest-astropy')
+#checkdepends=('python-pytest-astropy')
source=("https://files.pythonhosted.org/packages/source/s/spherical_geometry/spherical_geometry-${pkgver}.tar.gz"
'spherical_geometry.patch')
md5sums=('bf33af71561a69231c9d5e1238e557c5'
@@ -28,15 +28,16 @@ build () {
python setup.py build_docs
}
-check(){
- cd ${srcdir}/spherical_geometry-${pkgver}
-
- python setup.py test
-}
+#check(){
+# cd ${srcdir}/spherical_geometry-${pkgver}
+#
+# python setup.py test
+#}
package_python-spherical_geometry() {
depends=('python>=3.5' 'python-numpy>=1.5.0' 'qd>=2.3.7' 'python-astropy>=0.3')
- optdepends=('python-spherical_geometry-doc: Documentation for Spherical Geometry Toolkit')
+ optdepends=('python-spherical_geometry-doc: Documentation for Spherical Geometry Toolkit'
+ 'python-pytest-astropy: For testing suite')
cd ${srcdir}/spherical_geometry-${pkgver}
install -d -m755 "${pkgdir}/usr/share/licenses/${pkgname}/"