summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2018-07-01 11:32:52 +0800
committerUniversebenzene2018-07-01 11:32:52 +0800
commitf9b4f135107080abeca97bbdae922c8db1f454a5 (patch)
tree3bfe854d83c8bcdec6e0f09023fdd2b6b7251fa9
parent10f578ec1bee0e518a69c6d314ae721525648454 (diff)
downloadaur-f9b4f135107080abeca97bbdae922c8db1f454a5.tar.gz
Update to version 1.2.4
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD6
-rw-r--r--spherical_geometry.patch13
3 files changed, 19 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fa4fb2bdf62b..8f77b43f715a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Jun 22 04:51:09 UTC 2018
+# Sat Jun 30 14:02:23 UTC 2018
pkgbase = python-spherical_geometry
pkgdesc = Python based tools for spherical geometry
- pkgver = 1.2.3
+ pkgver = 1.2.4
pkgrel = 1
url = http://www.stsci.edu/resources/software_hardware/stsci_python
arch = i686
@@ -15,10 +15,10 @@ pkgbase = python-spherical_geometry
makedepends = python-astropy-helpers
makedepends = python-sphinx
makedepends = python-matplotlib
- source = https://files.pythonhosted.org/packages/source/s/spherical_geometry/spherical_geometry-1.2.3.tar.gz
+ source = https://files.pythonhosted.org/packages/source/s/spherical_geometry/spherical_geometry-1.2.4.tar.gz
source = spherical_geometry.patch
- md5sums = 5637d7b3298430b1872f4fc92ebb22f5
- md5sums = 3f0d22573ec591a015a120faf1854bef
+ md5sums = cbc8d64916f3c9dcfd5c7a5ca9df8640
+ md5sums = bf3b812ddc47c2d8fcbfb2c3179fbc24
pkgname = python-spherical_geometry
depends = python>=3.5
diff --git a/PKGBUILD b/PKGBUILD
index 4a38503d3edc..ed10e5f21362 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
pkgbase=python-spherical_geometry
pkgname=('python-spherical_geometry' 'python-spherical_geometry-doc')
-pkgver=1.2.3
+pkgver=1.2.4
pkgrel=1
pkgdesc="Python based tools for spherical geometry"
arch=('i686' 'x86_64')
@@ -11,8 +11,8 @@ makedepends=('cython' 'qd>=2.3.7' 'python-astropy>=3.0' 'python-astropy-helpers'
checkdepends=('python-pytest-astropy')
source=("https://files.pythonhosted.org/packages/source/s/spherical_geometry/spherical_geometry-${pkgver}.tar.gz"
'spherical_geometry.patch')
-md5sums=('5637d7b3298430b1872f4fc92ebb22f5'
- '3f0d22573ec591a015a120faf1854bef')
+md5sums=('cbc8d64916f3c9dcfd5c7a5ca9df8640'
+ 'bf3b812ddc47c2d8fcbfb2c3179fbc24')
prepare() {
cd ${srcdir}/spherical_geometry-${pkgver}
diff --git a/spherical_geometry.patch b/spherical_geometry.patch
index e519f713366a..716156e25eb5 100644
--- a/spherical_geometry.patch
+++ b/spherical_geometry.patch
@@ -1,5 +1,5 @@
--- a/README.rst 2018-02-22 23:21:38.000000000 +0800
-+++ b/README.rst 2018-05-06 16:14:13.548738696 +0800
++++ b/README.rst 2018-06-30 21:44:05.756359550 +0800
@@ -102,6 +102,8 @@
Disjoint Polygons
^^^^^^^^^^^^^^^^^
@@ -9,8 +9,17 @@
If a polygon is the result of the intersection of polygons, it may be disjoint.
Disjoint polygons are represented as a list of spherical polygons. The library
handles the details of this internally. However, the user must be aware that
+@@ -156,7 +158,7 @@
+ `~SphericalPolygon.multi_intersection`: Return a new polygon that
+ is the intersection of two or more polygons.
+
+- - `~SphericalPolygon.overlap`: Determine how much a given polygon
++ - `~SingleSphericalPolygon.overlap`: Determine how much a given polygon
+ overlaps another.
+
+ - `~SphericalPolygon.to_radec`: Convert (*x*, *y*, *z*) points in the
--- a/setup.cfg 2018-02-22 23:21:38.000000000 +0800
-+++ b/setup.cfg 2018-05-06 16:13:56.131595995 +0800
++++ b/setup.cfg 2018-06-30 21:42:29.061892875 +0800
@@ -12,7 +12,7 @@
norecursedirs = .git build docs/_build