summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Wolsieffer2018-04-16 20:13:49 -0400
committerBen Wolsieffer2018-04-16 20:13:49 -0400
commit77e25911622955598537be295c71e2b71eac8d0d (patch)
tree37e2febe06bb0f859cc8a005508d78ba97554d2f
parent346b067ae6b429fe37c3ec0c4d3195cc0c5c3e96 (diff)
downloadaur-77e25911622955598537be295c71e2b71eac8d0d.tar.gz
Update to 0.2.2
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD10
2 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b88ecca3f403..365511b3a591 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Dec 10 03:18:51 UTC 2017
+# Tue Apr 17 00:13:38 UTC 2018
pkgbase = python-sphinx-argparse
pkgdesc = Sphinx extension that automatically documents argparse commands and options.
- pkgver = 0.2.1
- pkgrel = 2
+ pkgver = 0.2.2
+ pkgrel = 1
url = https://github.com/ribozz/sphinx-argparse
arch = any
license = MIT
@@ -12,14 +12,14 @@ pkgbase = python-sphinx-argparse
makedepends = git
makedepends = python-setuptools
makedepends = python2-setuptools
- source = sphinx-argparse::git+https://github.com/ribozz/sphinx-argparse.git#tag=0.2.1
+ source = sphinx-argparse::git+https://github.com/ribozz/sphinx-argparse.git#tag=0.2.2
sha256sums = SKIP
pkgname = python-sphinx-argparse
depends = python-sphinx
- depends = python-commonmark
+ optdepends = python-commonmark: markdown support
pkgname = python2-sphinx-argparse
depends = python2-sphinx
- depends = python2-commonmark
+ optdepends = python2-commonmark: markdown support
diff --git a/PKGBUILD b/PKGBUILD
index f7e7b04ca3ad..d5c9e77c2d33 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@ _py_pkgname=sphinx-argparse
_github_url=https://github.com/ribozz/sphinx-argparse
pkgbase=python-${_py_pkgname}
pkgname=(python-${_py_pkgname} python2-${_py_pkgname})
-pkgver=0.2.1
-pkgrel=2
+pkgver=0.2.2
+pkgrel=1
pkgdesc="Sphinx extension that automatically documents argparse commands and options."
arch=('any')
url="${_github_url}"
@@ -31,7 +31,8 @@ check() {
# Automatically create package functions using Bash magic
source /dev/stdin << EOF
package_python-${_py_pkgname}() {
- depends=('python-sphinx' 'python-commonmark')
+ depends=('python-sphinx')
+ optdepends=('python-commonmark: markdown support')
cd "\${srcdir}/${_py_pkgname}"
@@ -41,7 +42,8 @@ package_python-${_py_pkgname}() {
}
package_python2-${_py_pkgname}() {
- depends=('python2-sphinx' 'python2-commonmark')
+ depends=('python2-sphinx')
+ optdepends=('python2-commonmark: markdown support')
cd "\${srcdir}/${_py_pkgname}"