summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2023-03-21 14:24:32 +0800
committerUniversebenzene2023-03-21 14:24:32 +0800
commit568e3dc4beb49a7475234092133338a191023c69 (patch)
treecdf193ddb3221153ac56963f23a3d855f3ad2417
parentd36d6b251142e3d94ecd6c2d75485f23c6410194 (diff)
downloadaur-568e3dc4beb49a7475234092133338a191023c69.tar.gz
Change sphinxcontrib-jquery into community version
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 138af5a62f2f..36851e882069 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = python-sphinx-astropy
pkgdesc = Sphinx extensions and configuration specific to the Astropy project
pkgver = 1.8.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/astropy/sphinx-astropy
arch = any
license = BSD
checkdepends = python-pytest-doctestplus
checkdepends = python-astropy-sphinx-theme
checkdepends = python-numpydoc
- checkdepends = python-sphinxcontrib.jquery
+ checkdepends = python-sphinxcontrib-jquery
checkdepends = python-sphinx-automodapi
makedepends = python-setuptools-scm
makedepends = python-wheel
@@ -24,6 +24,6 @@ pkgname = python-sphinx-astropy
depends = python-sphinx-automodapi
depends = python-sphinx-gallery
depends = python-numpydoc
- depends = python-sphinxcontrib.jquery
+ depends = python-sphinxcontrib-jquery
depends = python-pillow
depends = python-pytest-doctestplus>=0.11
diff --git a/PKGBUILD b/PKGBUILD
index 132ba5bf315a..6b5be7f49575 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=python-sphinx-astropy
_pyname=${pkgname#python-}
pkgver=1.8.0
-pkgrel=1
+pkgrel=2
pkgdesc="Sphinx extensions and configuration specific to the Astropy project"
arch=('any')
url="https://github.com/astropy/sphinx-astropy"
@@ -14,7 +14,7 @@ makedepends=('python-setuptools-scm'
checkdepends=('python-pytest-doctestplus'
'python-astropy-sphinx-theme'
'python-numpydoc'
- 'python-sphinxcontrib.jquery'
+ 'python-sphinxcontrib-jquery'
'python-sphinx-automodapi'
)
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
@@ -29,7 +29,9 @@ build() {
check() {
cd ${srcdir}/${_pyname}-${pkgver}
- pytest || warning "Tests failed" # -vv --color=yes
+ # skip tests that cost times through internet
+ pytest -vv --color=yes \
+ --deselect=sphinx_astropy/tests/test_conf.py::test_conf #|| warning "Tests failed" # -vv --color=yes
}
package() {
@@ -39,7 +41,7 @@ package() {
'python-sphinx-automodapi'
'python-sphinx-gallery'
'python-numpydoc'
- 'python-sphinxcontrib.jquery'
+ 'python-sphinxcontrib-jquery'
'python-pillow'
'python-pytest-doctestplus>=0.11')
cd ${srcdir}/${_pyname}-${pkgver}