summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2018-09-09 17:41:59 +0800
committerUniversebenzene2018-09-09 17:41:59 +0800
commit58a3cb3180831b114a911d277d346867e2ba4fab (patch)
tree349cd3092a2121a8da3ccd3775c408894382dd35
downloadaur-58a3cb3180831b114a911d277d346867e2ba4fab.tar.gz
Initial import 1.0
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD20
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c760dded8276
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Sun Sep 9 09:41:52 UTC 2018
+pkgbase = python-sphinx-astropy
+ pkgdesc = Sphinx extensions and configuration specific to the Astropy project
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/astropy/sphinx-astropy
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = python-setuptools
+ depends = python-sphinx>=1.4
+ depends = python-astropy-sphinx-theme
+ depends = python-sphinx-automodapi
+ depends = python-sphinx-gallery
+ depends = python-numpydoc
+ source = https://files.pythonhosted.org/packages/source/s/sphinx-astropy/sphinx-astropy-1.0.tar.gz
+ md5sums = 4d43b57e439a0e5c42536043a0ca69e8
+
+pkgname = python-sphinx-astropy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..874dad46d6d4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Astro Benzene <universebenzene at sina dot com>
+pkgname=python-sphinx-astropy
+pkgver=1.0
+pkgrel=1
+pkgdesc="Sphinx extensions and configuration specific to the Astropy project"
+arch=('i686' 'x86_64')
+url="https://github.com/astropy/sphinx-astropy"
+license=('BSD')
+depends=('python-sphinx>=1.4' 'python-astropy-sphinx-theme' 'python-sphinx-automodapi' 'python-sphinx-gallery' 'python-numpydoc')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/s/sphinx-astropy/sphinx-astropy-${pkgver}.tar.gz")
+md5sums=('4d43b57e439a0e5c42536043a0ca69e8')
+
+package() {
+ cd ${srcdir}/sphinx-astropy-${pkgver}
+
+ install -D -m644 LICENSE.rst -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -D -m644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
+ python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
+}