summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Wolsieffer2018-07-29 13:41:14 -0400
committerBen Wolsieffer2018-07-29 13:41:14 -0400
commit983314f1258498201db1a24976a37fbce72e0414 (patch)
tree65ddeea775a4e85f8f3762e1f5bdb5468166cd21
parent693e884a20820020cf5fe641bf4d7dfdf07db373 (diff)
downloadaur-983314f1258498201db1a24976a37fbce72e0414.tar.gz
Fix compatibility with port-for 0.4
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
2 files changed, 17 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b9620eb5cc82..09e5cdecfbf0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Oct 2 13:17:33 UTC 2017
+# Sun Jul 29 17:40:51 UTC 2018
pkgbase = python-sphinx-autobuild
pkgdesc = Watch a Sphinx directory and rebuild the documentation when a change is detected. Also includes a livereload enabled web server.
pkgver = 0.7.1
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/GaretJax/sphinx-autobuild
arch = any
license = MIT
@@ -18,7 +18,9 @@ pkgbase = python-sphinx-autobuild
checkdepends = python2-pytest
checkdepends = python2-mock
source = https://files.pythonhosted.org/packages/source/s/sphinx-autobuild/sphinx-autobuild-0.7.1.tar.gz
+ source = dependency-updates.patch::https://github.com/GaretJax/sphinx-autobuild/commit/08c4198a971d40abd6293bb54b3336f081b2bb6e.patch
sha256sums = 66388f81884666e3821edbe05dd53a0cfb68093873d17320d0610de8db28c74e
+ sha256sums = 896ef9038482a183bee7ae2a45315fae77edc81a70c3c196498edff1b4c8fc4b
pkgname = python-sphinx-autobuild
depends = python-sphinx
diff --git a/PKGBUILD b/PKGBUILD
index 2fe29fb20a00..64a59de9010b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ _py_pkgname=sphinx-autobuild
pkgbase=python-${_py_pkgname}
pkgname=(python-${_py_pkgname} python2-${_py_pkgname})
pkgver=0.7.1
-pkgrel=3
+pkgrel=4
pkgdesc="Watch a Sphinx directory and rebuild the documentation when a change is detected. Also includes a livereload enabled web server."
arch=('any')
url="https://github.com/GaretJax/sphinx-autobuild"
@@ -20,8 +20,18 @@ checkdepends=(
'python2-pytest'
'python2-mock'
)
-source=("https://files.pythonhosted.org/packages/source/${_py_pkgname::1}/${_py_pkgname}/${_py_pkgname}-${pkgver}.tar.gz")
-sha256sums=('66388f81884666e3821edbe05dd53a0cfb68093873d17320d0610de8db28c74e')
+source=(
+ "https://files.pythonhosted.org/packages/source/${_py_pkgname::1}/${_py_pkgname}/${_py_pkgname}-${pkgver}.tar.gz"
+ "dependency-updates.patch::https://github.com/GaretJax/sphinx-autobuild/commit/08c4198a971d40abd6293bb54b3336f081b2bb6e.patch"
+)
+sha256sums=('66388f81884666e3821edbe05dd53a0cfb68093873d17320d0610de8db28c74e'
+ '896ef9038482a183bee7ae2a45315fae77edc81a70c3c196498edff1b4c8fc4b')
+
+prepare() {
+ cd "${srcdir}/${_py_pkgname}-${pkgver}"
+
+ patch -p1 < ../dependency-updates.patch
+}
build() {
cd "${srcdir}/${_py_pkgname}-${pkgver}"