summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartino Pilia2018-03-18 15:33:25 +0100
committerMartino Pilia2018-03-18 15:33:25 +0100
commit7aac2e791a952759063e501e85dbfbc14b70533e (patch)
tree8ab0ab2e890b2a5b15a910fccbe68a6a8d476526
downloadaur-7aac2e791a952759063e501e85dbfbc14b70533e.tar.gz
new package
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD20
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..053b1959799c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-sphinx-autodoc-typehints
+ pkgdesc = Type hints support for the Sphinx autodoc extension
+ pkgver = 1.2.5
+ pkgrel = 1
+ url = https://github.com/agronholm/sphinx-autodoc-typehints
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-sphinx
+ source = https://files.pythonhosted.org/packages/source/s/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.2.5.tar.gz
+ md5sums = 077df942f0b552722d79a146098c0a05
+
+pkgname = python-sphinx-autodoc-typehints
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f93b66b609f1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Martino Pilia <martino.pilia@gmail.com>
+_pkgname=sphinx-autodoc-typehints
+pkgname=python-$_pkgname
+pkgver=1.2.5
+pkgrel=1
+pkgdesc="Type hints support for the Sphinx autodoc extension"
+arch=('any')
+url="https://github.com/agronholm/sphinx-autodoc-typehints"
+license=('MIT')
+depends=('python-sphinx')
+optdepends=()
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+md5sums=('077df942f0b552722d79a146098c0a05')
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ install -D -m644 ${srcdir}/$_pkgname-$pkgver/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ python setup.py install --optimize=1 --root=$pkgdir
+}