summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartino Pilia2019-08-04 15:09:09 +0200
committerMartino Pilia2019-08-04 15:09:09 +0200
commitda879bb29c2279ba753a516d78a8399a2951c252 (patch)
tree2c9000b2dda5257b455b764e0bdc8156853912ce
parent7abd65c26ce40dba3243e8ccadb7b5107da779d2 (diff)
downloadaur-da879bb29c2279ba753a516d78a8399a2951c252.tar.gz
Version 1.7.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 111bbc4689ad..c60a38f36f89 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = python-sphinx-autodoc-typehints
pkgdesc = Type hints support for the Sphinx autodoc extension
- pkgver = 1.6.0
+ pkgver = 1.7.0
pkgrel = 1
url = https://github.com/agronholm/sphinx-autodoc-typehints
arch = any
license = MIT
makedepends = python-setuptools
depends = python-sphinx
- source = https://files.pythonhosted.org/packages/source/s/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.6.0.tar.gz
- sha256sums = f9c06acfec80766fe8f542a6d6a042e751fcf6ce2e2711a7dc00d8b6daf8aa36
+ source = https://files.pythonhosted.org/packages/source/s/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.7.0.tar.gz
+ sha256sums = 8eb1e2bc248d316a9faeca086c6133623f6d45770e342738158249356989b95c
pkgname = python-sphinx-autodoc-typehints
diff --git a/PKGBUILD b/PKGBUILD
index 3fbab84a7243..31ef28657187 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer of this PKGBUILD file: Martino Pilia <martino.pilia@gmail.com>
_pkgname=sphinx-autodoc-typehints
pkgname=python-$_pkgname
-pkgver=1.6.0
+pkgver=1.7.0
pkgrel=1
pkgdesc="Type hints support for the Sphinx autodoc extension"
arch=('any')
@@ -11,10 +11,10 @@ depends=('python-sphinx')
optdepends=()
makedepends=('python-setuptools')
source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
-sha256sums=('f9c06acfec80766fe8f542a6d6a042e751fcf6ce2e2711a7dc00d8b6daf8aa36')
+sha256sums=('8eb1e2bc248d316a9faeca086c6133623f6d45770e342738158249356989b95c')
package() {
cd "$srcdir/$_pkgname-$pkgver"
- install -D -m644 ${srcdir}/$_pkgname-$pkgver/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- python setup.py install --optimize=1 --root=$pkgdir
+ install -D -m644 "${srcdir}/$_pkgname-$pkgver/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ python setup.py install --optimize=1 --root="$pkgdir"
}