summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2019-11-27 22:00:13 +0800
committerUniversebenzene2019-11-27 22:00:13 +0800
commit809ed8764069c4770e8e8ec2179cfbd38b7bbefd (patch)
tree38eb516b67fc8b6c5b34765babec11c055976b41
parentdcfc7f070812b703fd3db35c5155a3aff2d28868 (diff)
downloadaur-809ed8764069c4770e8e8ec2179cfbd38b7bbefd.tar.gz
Update to version 2.3.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a930171d69e8..e45e509a78b2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,21 @@
pkgbase = python-sphinx-click
pkgdesc = Sphinx extension that automatically documents click applications
- pkgver = 2.3.0
+ pkgver = 2.3.1
pkgrel = 1
url = https://sphinx-click.readthedocs.io
arch = i686
arch = x86_64
license = MIT
- checkdepends = python-coverage
- checkdepends = python2-coverage
+ checkdepends = python-pytest
+ checkdepends = python2-pytest
checkdepends = python2-sphinx
checkdepends = python-click
checkdepends = python2-click
makedepends = python-setuptools
makedepends = python2-setuptools
makedepends = python-sphinx
- source = https://files.pythonhosted.org/packages/source/s/sphinx-click/sphinx-click-2.3.0.tar.gz
- md5sums = 1fb18f64123fa583d2dc7ef3e04ba583
+ source = https://files.pythonhosted.org/packages/source/s/sphinx-click/sphinx-click-2.3.1.tar.gz
+ md5sums = a3d1b7af95a2284d71bee6d9b513acf1
pkgname = python-sphinx-click
depends = python-sphinx>=1.5
diff --git a/PKGBUILD b/PKGBUILD
index edbed004ee8f..fb63e29d60da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,17 @@
pkgbase=python-sphinx-click
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}" "python2-${_pyname}" "python-${_pyname}-doc")
-pkgver=2.3.0
+pkgver=2.3.1
pkgrel=1
pkgdesc="Sphinx extension that automatically documents click applications"
arch=('i686' 'x86_64')
url="https://sphinx-click.readthedocs.io"
license=('MIT')
makedepends=('python-setuptools' 'python2-setuptools' 'python-sphinx')
-checkdepends=('python-coverage' 'python2-coverage' 'python2-sphinx' 'python-click' 'python2-click')
+#checkdepends=('python-coverage' 'python2-coverage' 'python2-sphinx' 'python-click' 'python2-click')
+checkdepends=('python-pytest' 'python2-pytest' 'python2-sphinx' 'python-click' 'python2-click')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('1fb18f64123fa583d2dc7ef3e04ba583')
+md5sums=('a3d1b7af95a2284d71bee6d9b513acf1')
prepare() {
cd ${srcdir}/${_pyname}-${pkgver}
@@ -36,11 +37,13 @@ build() {
check() {
msg "Checking Python3"
cd ${srcdir}/${_pyname}-${pkgver}
- python setup.py test
+# python setup.py test
+ pytest
msg "Checking Python2"
cd ${srcdir}/${_pyname}-${pkgver}-py2
- python2 setup.py test
+# python2 setup.py test
+ pytest2
}
package_python2-sphinx-click() {
@@ -67,6 +70,7 @@ package_python-sphinx-click-doc() {
pkgdesc="Documentation for sphinx-click"
cd ${srcdir}/${_pyname}-${pkgver}/build/sphinx
+ install -D -m644 -t "${pkgdir}/usr/share/licenses/${pkgname}" ../../LICENSE
install -d -m755 "${pkgdir}/usr/share/doc/${pkgbase}"
cp -a html "${pkgdir}/usr/share/doc/${pkgbase}"
}