summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYour Name2024-04-18 11:15:18 +0800
committerYour Name2024-04-18 11:15:18 +0800
commitf0e2e41f0175c81182411a8c7df43ef679be5fa6 (patch)
tree507f113087d5b5e34a2e41c38bc3d0026f0618b7
parent6b6f41b3499376e0c7d2f4e7988967a1294274cd (diff)
downloadaur-f0e2e41f0175c81182411a8c7df43ef679be5fa6.tar.gz
Update to version 0.15.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
2 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d4c537c33934..5f3dd825effa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-sphinx-codeautolink
pkgdesc = Automatic links from code examples to reference documentation
- pkgver = 0.15.0
+ pkgver = 0.15.1
pkgrel = 1
url = https://sphinx-codeautolink.readthedocs.io
arch = any
@@ -12,12 +12,12 @@ pkgbase = python-sphinx-codeautolink
makedepends = python-installer
makedepends = python-sphinx
makedepends = python-sphinx_rtd_theme
- makedepends = python-beautifulsoup4
makedepends = python-matplotlib
makedepends = ipython
- source = https://files.pythonhosted.org/packages/source/s/sphinx-codeautolink/sphinx-codeautolink-0.15.0.tar.gz
+ makedepends = python-beautifulsoup4
+ source = https://files.pythonhosted.org/packages/source/s/sphinx_codeautolink/sphinx_codeautolink-0.15.1.tar.gz
source = Makefile
- md5sums = 8bc7687a42b720e1d6462d4a4f18abc7
+ md5sums = 619afb4a57da0becf56c7f982ffe8091
md5sums = a6aa4bc42b138d75f938065a0994c3e1
pkgname = python-sphinx-codeautolink
diff --git a/PKGBUILD b/PKGBUILD
index 3324827d82da..c119ad800956 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
pkgbase=python-sphinx-codeautolink
-_pyname=${pkgbase#python-}
-pkgname=("python-${_pyname}" "python-${_pyname}-doc")
-pkgver=0.15.0
+_pname=${pkgbase#python-}
+_pyname=${_pname//-/_}
+pkgname=("python-${_pname}" "python-${_pname}-doc")
+pkgver=0.15.1
pkgrel=1
pkgdesc="Automatic links from code examples to reference documentation"
arch=('any')
@@ -14,13 +15,13 @@ makedepends=('python-setuptools'
'python-installer'
'python-sphinx'
'python-sphinx_rtd_theme'
- 'python-beautifulsoup4'
'python-matplotlib'
- 'ipython')
+ 'ipython'
+ 'python-beautifulsoup4')
checkdepends=('python-pytest') # sphinx, bs4, ipython already in makedepends
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz"
'Makefile')
-md5sums=('8bc7687a42b720e1d6462d4a4f18abc7'
+md5sums=('619afb4a57da0becf56c7f982ffe8091'
'a6aa4bc42b138d75f938065a0994c3e1')
prepare() {
@@ -40,7 +41,7 @@ build() {
check() {
cd ${srcdir}/${_pyname}-${pkgver}
- PYTHONPATH="build/lib" pytest || warning "Tests failed" # -vv --color=yes
+ PYTHONPATH="build/lib" pytest || warning "Tests failed" # -vv -l -ra --color=yes -o console_output_style=count
}
package_python-sphinx-codeautolink() {