summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBlair Bonnett2020-01-04 17:06:04 +0100
committerBlair Bonnett2020-01-04 17:06:04 +0100
commit0375fbc8203035c6e628843a7975e10bf979acf9 (patch)
tree972b210f1011e1ce26c378e74bebe2513ee8c293
parentaa069082df9ce3690dd2cbd5aed3b29f02565916 (diff)
downloadaur-0375fbc8203035c6e628843a7975e10bf979acf9.tar.gz
Update to 0.2.8.
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD20
3 files changed, 22 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 706febb770f8..481dfeea8b39 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = python-sphinx-copybutton
- pkgdesc = A Sphinx extension to add a "copy" button to code blocks
- pkgver = 0.2.5
+ pkgdesc = Sphinx extension to add a "copy" button to code blocks
+ pkgver = 0.2.8
pkgrel = 1
- url = https://github.com/choldgraf/sphinx-copybutton
+ url = https://sphinx-copybutton.readthedocs.io/
arch = any
license = MIT
+ makedepends = python-setuptools
depends = python-sphinx
- source = https://files.pythonhosted.org/packages/source/s/sphinx-copybutton/sphinx-copybutton-0.2.5.tar.gz
- sha256sums = 94593d9fd7318fa119ae4144fc99a91cb5cd4523adb363b6a93ee9b2ad0160ae
+ source = https://files.pythonhosted.org/packages/source/s/sphinx-copybutton/sphinx-copybutton-0.2.8.tar.gz
+ sha256sums = 48aec91c44af057e4a59fba962493e09dd992b13d2555d5776e8a701420a5308
pkgname = python-sphinx-copybutton
diff --git a/.gitignore b/.gitignore
index dbf3fdd9285b..ce0c44eaf5c1 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,6 @@
src
pkg
*.pkg.tar.xz
+*.pkg.tar.zst
*.tar.gz
+*.log
diff --git a/PKGBUILD b/PKGBUILD
index d6aaf1e86d87..afb6077a92e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,19 @@
# Maintainer: Blair Bonnett <blair dot bonnett at gmail dot com>
pkgname=python-sphinx-copybutton
-pkgver=0.2.5
+pkgver=0.2.8
pkgrel=1
-pkgdesc="A Sphinx extension to add a \"copy\" button to code blocks"
-url="https://github.com/choldgraf/sphinx-copybutton"
+pkgdesc="Sphinx extension to add a \"copy\" button to code blocks"
+url="https://sphinx-copybutton.readthedocs.io/"
arch=('any')
license=('MIT')
depends=('python-sphinx')
+makedepends=('python-setuptools')
source=(
"https://files.pythonhosted.org/packages/source/s/sphinx-copybutton/sphinx-copybutton-$pkgver.tar.gz"
)
sha256sums=(
- "94593d9fd7318fa119ae4144fc99a91cb5cd4523adb363b6a93ee9b2ad0160ae"
+ '48aec91c44af057e4a59fba962493e09dd992b13d2555d5776e8a701420a5308'
)
build() {
@@ -22,6 +23,13 @@ build() {
package() {
cd "sphinx-copybutton-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
- install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ python setup.py install --root="$pkgdir/" --optimize=1 --prefix=/usr --skip-build
+ install -D -m644 -t "${pkgdir}/usr/share/licenses/${pkgname}" LICENSE
+ install -D -m644 -t "${pkgdir}/usr/share/doc/${pkgname}" README.md
+
+ # Files in the tarball are marked executable, leading to the files in the
+ # installed _static and egg-info directories being executable. Fix that.
+ PYVER=$(python -c 'import sys; print("{}.{}".format(*sys.version_info[:2]))')
+ chmod 644 "$pkgdir/usr/lib/python$PYVER/site-packages/sphinx_copybutton/_static/"*
+ chmod 644 "$pkgdir/usr/lib/python$PYVER/site-packages/sphinx_copybutton-$pkgver-py$PYVER.egg-info/"*
}