summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBlair Bonnett2020-04-24 16:32:57 +0200
committerBlair Bonnett2020-04-24 16:32:57 +0200
commit12fe987cfd05439f9d9b2510f67bc383fbc88a9b (patch)
treee20762498bc06b8e34fde0f862c437883ee84aef
parent48579640d812ce56054570d6cea6e944c7196970 (diff)
downloadaur-12fe987cfd05439f9d9b2510f67bc383fbc88a9b.tar.gz
Update to 0.2.11.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 5 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bf326abaec7f..42f5c2edd3cd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = python-sphinx-copybutton
pkgdesc = Sphinx extension to add a "copy" button to code blocks
- pkgver = 0.2.10
+ pkgver = 0.2.11
pkgrel = 1
url = https://sphinx-copybutton.readthedocs.io/
arch = any
license = MIT
makedepends = python-setuptools
depends = python-sphinx
- source = https://files.pythonhosted.org/packages/source/s/sphinx-copybutton/sphinx-copybutton-0.2.10.tar.gz
- sha256sums = 78d8ab9aded92275d2de8986e78c3857b9bdf5c5e0feac96a792a772f73bdf5d
+ source = https://files.pythonhosted.org/packages/source/s/sphinx-copybutton/sphinx-copybutton-0.2.11.tar.gz
+ sha256sums = cf3bb6dc4b82217fe1a765d733aa478949ae8574670aa2c5e7c94de81326ad50
pkgname = python-sphinx-copybutton
diff --git a/PKGBUILD b/PKGBUILD
index 5287e3fc8db0..6bc03aedd77a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Blair Bonnett <blair dot bonnett at gmail dot com>
pkgname=python-sphinx-copybutton
-pkgver=0.2.10
+pkgver=0.2.11
pkgrel=1
pkgdesc="Sphinx extension to add a \"copy\" button to code blocks"
url="https://sphinx-copybutton.readthedocs.io/"
@@ -13,7 +13,7 @@ source=(
"https://files.pythonhosted.org/packages/source/s/sphinx-copybutton/sphinx-copybutton-$pkgver.tar.gz"
)
sha256sums=(
- '78d8ab9aded92275d2de8986e78c3857b9bdf5c5e0feac96a792a772f73bdf5d'
+ 'cf3bb6dc4b82217fe1a765d733aa478949ae8574670aa2c5e7c94de81326ad50'
)
build() {
@@ -26,10 +26,4 @@ package() {
python setup.py install --root="$pkgdir/" --optimize=1 --prefix=/usr --skip-build
install -D -m644 -t "${pkgdir}/usr/share/licenses/${pkgname}" LICENSE
install -D -m644 -t "${pkgdir}/usr/share/doc/${pkgname}" README.md
-
- # Files in the tarball are marked executable, leading to the files in the
- # installed _static and egg-info directories being executable. Fix that.
- PYVER=$(python -c 'import sys; print("{}.{}".format(*sys.version_info[:2]))')
- chmod 644 "$pkgdir/usr/lib/python$PYVER/site-packages/sphinx_copybutton/_static/"*
- chmod 644 "$pkgdir/usr/lib/python$PYVER/site-packages/sphinx_copybutton-$pkgver-py$PYVER.egg-info/"*
}