summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBlair Bonnett2019-09-13 16:53:13 +0200
committerBlair Bonnett2019-09-13 16:53:13 +0200
commitaa069082df9ce3690dd2cbd5aed3b29f02565916 (patch)
tree0f2105ee45d118e51d4196673a4d569db50722ec
downloadaur-aa069082df9ce3690dd2cbd5aed3b29f02565916.tar.gz
Initial package: version 0.2.5
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD27
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..706febb770f8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-sphinx-copybutton
+ pkgdesc = A Sphinx extension to add a "copy" button to code blocks
+ pkgver = 0.2.5
+ pkgrel = 1
+ url = https://github.com/choldgraf/sphinx-copybutton
+ arch = any
+ license = MIT
+ depends = python-sphinx
+ source = https://files.pythonhosted.org/packages/source/s/sphinx-copybutton/sphinx-copybutton-0.2.5.tar.gz
+ sha256sums = 94593d9fd7318fa119ae4144fc99a91cb5cd4523adb363b6a93ee9b2ad0160ae
+
+pkgname = python-sphinx-copybutton
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..dbf3fdd9285b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src
+pkg
+*.pkg.tar.xz
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d6aaf1e86d87
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Blair Bonnett <blair dot bonnett at gmail dot com>
+
+pkgname=python-sphinx-copybutton
+pkgver=0.2.5
+pkgrel=1
+pkgdesc="A Sphinx extension to add a \"copy\" button to code blocks"
+url="https://github.com/choldgraf/sphinx-copybutton"
+arch=('any')
+license=('MIT')
+depends=('python-sphinx')
+source=(
+ "https://files.pythonhosted.org/packages/source/s/sphinx-copybutton/sphinx-copybutton-$pkgver.tar.gz"
+)
+sha256sums=(
+ "94593d9fd7318fa119ae4144fc99a91cb5cd4523adb363b6a93ee9b2ad0160ae"
+)
+
+build() {
+ cd "sphinx-copybutton-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "sphinx-copybutton-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}