summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2020-12-18 12:26:59 +0800
committerUniversebenzene2020-12-18 12:26:59 +0800
commit4c3c718c4530a3f53cc2db31b03280ec71c89809 (patch)
tree836cea4875c8baaaa85652703202fefb03b91e9a
parent4e782a477cd53022161ddd279c5d277da4c99ebd (diff)
downloadaur-4c3c718c4530a3f53cc2db31b03280ec71c89809.tar.gz
Update to version 0.8.2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
2 files changed, 12 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 67b8035bb19d..ee8a686b5fbb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-sphinx-gallery
pkgdesc = Sphinx extension to automatically generate an examples gallery
- pkgver = 0.8.1
- pkgrel = 2
+ pkgver = 0.8.2
+ pkgrel = 1
url = http://sphinx-gallery.github.io
arch = i686
arch = x86_64
@@ -12,8 +12,8 @@ pkgbase = python-sphinx-gallery
checkdepends = python-sphinx
checkdepends = python-joblib
makedepends = python-setuptools
- source = https://files.pythonhosted.org/packages/source/s/sphinx-gallery/sphinx-gallery-0.8.1.tar.gz
- md5sums = 4f14e3130eb6862d2d5948ca57e69f86
+ source = https://files.pythonhosted.org/packages/source/s/sphinx-gallery/sphinx-gallery-0.8.2.tar.gz
+ md5sums = 2e8e42f95a6a49dbee35820b3204863f
pkgname = python-sphinx-gallery
depends = python-sphinx>=1.8.3
diff --git a/PKGBUILD b/PKGBUILD
index 64835991a975..365bb7a228de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@ pkgbase=python-sphinx-gallery
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}")
#"python-${_pyname}-doc")
-pkgver=0.8.1
-pkgrel=2
+pkgver=0.8.2
+pkgrel=1
pkgdesc="Sphinx extension to automatically generate an examples gallery"
arch=('i686' 'x86_64')
url="http://sphinx-gallery.github.io"
@@ -13,7 +13,7 @@ makedepends=('python-setuptools')
#'python-sphinx' 'python-pillow' 'python-scipy' 'python-seaborn')
checkdepends=('python-pytest-cov' 'python-matplotlib' 'python-pillow' 'python-sphinx' 'python-joblib')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('4f14e3130eb6862d2d5948ca57e69f86')
+md5sums=('2e8e42f95a6a49dbee35820b3204863f')
build() {
cd ${srcdir}/${_pyname}-${pkgver}
@@ -23,12 +23,11 @@ build() {
# python setup.py build_sphinx
}
-#check() {
-# cd ${srcdir}/${_pyname}-${pkgver}
-#
-## python setup.py test
-# pytest
-#}
+check() {
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+ pytest || warning "Tests failed"
+}
package_python-sphinx-gallery() {
depends=('python-sphinx>=1.8.3' 'python-pillow' 'python-matplotlib')