summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2018-06-18 22:18:52 +0800
committerUniversebenzene2018-06-18 22:20:16 +0800
commitf695fb8977613364097033bf0a8b7d19eb481377 (patch)
tree53b438d3e331f0649da226daf450cec87a2ee6ab
parent59bb9f125b5096ea1ffa92fc170f3bfa7f1b6644 (diff)
downloadaur-f695fb8977613364097033bf0a8b7d19eb481377.tar.gz
Update to version 0.2.0, add py2
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD41
2 files changed, 51 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7db4dc5b061c..49bb6c86a5be 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,25 @@
# Generated by mksrcinfo v8
-# Fri Feb 9 20:02:57 UTC 2018
+# Mon Jun 18 14:16:13 UTC 2018
pkgbase = python-sphinx-gallery
pkgdesc = Sphinx extension to automatically generate an examples gallery
- pkgver = 0.1.13
+ pkgver = 0.2.0
pkgrel = 1
url = http://sphinx-gallery.readthedocs.io/en/latest/
arch = i686
arch = x86_64
license = BSD
checkdepends = python-pytest-cov
+ checkdepends = python2-pytest-cov
+ checkdepends = python2-matplotlib
+ checkdepends = python2-sphinx
makedepends = python-setuptools
+ makedepends = python2-setuptools
makedepends = python-sphinx
makedepends = python-pillow
makedepends = python-scipy
makedepends = python-seaborn
- source = https://github.com/sphinx-gallery/sphinx-gallery/archive/v0.1.13.tar.gz
- md5sums = 688b4aa331bc3d292106913f76da20ae
+ source = https://github.com/sphinx-gallery/sphinx-gallery/archive/v0.2.0.tar.gz
+ md5sums = e2a05e0822b240c4c60afbabe9cc8a86
pkgname = python-sphinx-gallery
depends = python-sphinx
@@ -25,6 +29,14 @@ pkgname = python-sphinx-gallery
optdepends = mayavi-py3
optdepends = python-sphinx-gallery-doc: Documentation of Sphinx-Gallery
+pkgname = python2-sphinx-gallery
+ depends = python2-sphinx
+ depends = python2-matplotlib
+ depends = python2-pillow
+ optdepends = python2-seaborn
+ optdepends = mayavi
+ optdepends = python-sphinx-gallery-doc: Documentation of Sphinx-Gallery
+
pkgname = python-sphinx-gallery-doc
pkgdesc = Documentation for Sphinx-Gallery extension
diff --git a/PKGBUILD b/PKGBUILD
index cd78161a24a4..bcb1adb57615 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,29 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
pkgbase=python-sphinx-gallery
-pkgname=('python-sphinx-gallery' 'python-sphinx-gallery-doc')
-pkgver=0.1.13
+pkgname=('python-sphinx-gallery' 'python2-sphinx-gallery' 'python-sphinx-gallery-doc')
+pkgver=0.2.0
pkgrel=1
pkgdesc="Sphinx extension to automatically generate an examples gallery"
arch=('i686' 'x86_64')
url="http://sphinx-gallery.readthedocs.io/en/latest/"
license=('BSD')
-makedepends=('python-setuptools' 'python-sphinx' 'python-pillow' 'python-scipy' 'python-seaborn')
-checkdepends=('python-pytest-cov')
+makedepends=('python-setuptools' 'python2-setuptools' 'python-sphinx' 'python-pillow' 'python-scipy' 'python-seaborn')
+checkdepends=('python-pytest-cov' 'python2-pytest-cov' 'python2-matplotlib' 'python2-sphinx')
source=("https://github.com/sphinx-gallery/sphinx-gallery/archive/v${pkgver}.tar.gz")
-md5sums=('688b4aa331bc3d292106913f76da20ae')
+md5sums=('e2a05e0822b240c4c60afbabe9cc8a86')
+
+prepare() {
+ cd ${srcdir}/sphinx-gallery-${pkgver}
+
+ cp -a ${srcdir}/sphinx-gallery-${pkgver}{,-py2}
+}
build () {
+ msg "Building Python2"
+ cd ${srcdir}/sphinx-gallery-${pkgver}-py2
+ python2 setup.py build
+
+ msg "Building Python3"
cd ${srcdir}/sphinx-gallery-${pkgver}
python setup.py build
@@ -21,8 +32,26 @@ build () {
}
check() {
- cd $srcdir/sphinx-gallery-${pkgver}
+ cd ${srcdir}/sphinx-gallery-${pkgver}
python setup.py test
+
+ cd ${srcdir}/sphinx-gallery-${pkgver}-py2
+ python2 setup.py test
+}
+
+package_python2-sphinx-gallery() {
+ depends=('python2-sphinx' 'python2-matplotlib' 'python2-pillow')
+ optdepends=('python2-seaborn'
+ 'mayavi'
+ 'python-sphinx-gallery-doc: Documentation of Sphinx-Gallery')
+ cd ${srcdir}/sphinx-gallery-${pkgver}
+
+ install -D -m644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -D -m644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
+ python2 setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
+
+ mv ${pkgdir}/usr/bin/copy_sphinxgallery.sh ${pkgdir}/usr/bin/copy_sphinxgallery2.sh
+ mv ${pkgdir}/usr/bin/sphx_glr_python_to_jupyter.py ${pkgdir}/usr/bin/sphx_glr_python_to_jupyter2.py
}
package_python-sphinx-gallery() {