summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruno Santos2021-09-28 00:14:48 +0100
committerBruno Santos2021-09-28 00:14:48 +0100
commit259367da1568cb8e1aac358836d0ff5a8f4caf49 (patch)
tree436fbbbe5aad2969b9fef292ede877b46e4146b1
parent046f1f1843cbef4edd6685e996657b4c49e9d25d (diff)
downloadaur-259367da1568cb8e1aac358836d0ff5a8f4caf49.tar.gz
Fix v0.8.0 build
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD12
2 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 939c1d2577bc..5a0a4d34e7ed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,14 @@
pkgbase = python-sphinx-hawkmoth
pkgdesc = Sphinx autodoc C extension
pkgver = 0.8.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/jnikula/hawkmoth
arch = i686
arch = x86_64
license = BSD2
+ makedepends = python-build
+ makedepends = python-install
+ makedepends = python-wheel
depends = python-sphinx
depends = clang
source = https://github.com/jnikula/hawkmoth/archive/v0.8.0.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index afaf44c27e43..9a67bdcd3a51 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,23 @@
upstream_name=hawkmoth
pkgname=python-sphinx-hawkmoth
pkgver=0.8.0
-pkgrel=1
+pkgrel=2
pkgdesc='Sphinx autodoc C extension'
arch=('i686' 'x86_64')
url='https://github.com/jnikula/hawkmoth'
license=('BSD2')
depends=('python-sphinx' 'clang')
+makedepends=('python-build' 'python-install' 'python-wheel')
source=('https://github.com/jnikula/hawkmoth/archive/v'$pkgver'.tar.gz')
sha256sums=('caff752de4648cbf5317bbd8ebe3c60f6e744d1287a9c486a372cf64e4d25050')
+build() {
+ cd $srcdir/$upstream_name-$pkgver
+ python -m build --wheel --no-isolation
+}
+
package() {
- install -D -m644 $srcdir/$upstream_name-$pkgver/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
cd $srcdir/$upstream_name-$pkgver
- python setup.py install --optimize=1 --root=$pkgdir
+ python -m install --optimize=1 --destdir="$pkgdir" dist/*.whl
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}