summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruno Santos2023-10-28 22:34:27 +0100
committerBruno Santos2023-10-28 22:34:27 +0100
commitaaf68813855cd6cea0edd42d9d4b22b177fb005e (patch)
tree7299c720d1af774f4bd7cd30044f16b77d509f78
parent8a9283b286977629ee7116506bc0f00abdfa51f2 (diff)
downloadaur-aaf68813855cd6cea0edd42d9d4b22b177fb005e.tar.gz
Add check() stage
-rw-r--r--PKGBUILD5
1 files changed, 5 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4e6ad7929e22..0a62bc305245 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,6 +18,11 @@ build() {
python -m build --wheel --no-isolation
}
+check() {
+ cd $srcdir/$upstream_name-$pkgver
+ make test
+}
+
package() {
cd $srcdir/$upstream_name-$pkgver
python -m installer --compile-bytecode=1 --destdir="$pkgdir" dist/*.whl