summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruno Santos2018-12-06 00:23:26 +0100
committerBruno Santos2019-01-29 01:56:29 +0100
commit1beb3d8f21347b338cf7bd1ff5b83e7e3a750e54 (patch)
tree92707bc7affc997d1f8cf248c7760f279b79fb7e
downloadaur-1beb3d8f21347b338cf7bd1ff5b83e7e3a750e54.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD22
3 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fc144c9e6fa6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-sphinx-hawkmoth-git
+ pkgdesc = Sphinx autodoc C extension
+ pkgver = latest
+ pkgrel = 1
+ url = https://github.com/jnikula/hawkmoth
+ arch = i686
+ arch = x86_64
+ license = BSD2
+ depends = python-sphinx
+ depends = clang
+ provides = python-sphinx-hawkmoth
+ conflicts = python-sphinx-hawkmoth
+ source = git+https://github.com/jnikula/hawkmoth
+ md5sums = SKIP
+
+pkgname = python-sphinx-hawkmoth-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4766e94a746b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Bruno Santos <brunomanuelsantos@tecnico.ulisboa.pt>
+
+upstream_name=hawkmoth
+aur_name=python-sphinx-hawkmoth
+pkgname=$aur_name-git
+pkgver=latest
+pkgrel=1
+pkgdesc='Sphinx autodoc C extension'
+arch=('i686' 'x86_64')
+url='https://github.com/jnikula/hawkmoth'
+license=('BSD2')
+depends=('python-sphinx' 'clang')
+provides=($aur_name)
+conflicts=($aur_name)
+source=('git+https://github.com/jnikula/hawkmoth')
+md5sums=('SKIP')
+
+package() {
+ dest=$pkgdir/usr/lib/python3.7/site-packages/$aur_name
+ mkdir -p $dest
+ cp -r $srcdir/$upstream_name/$upstream_name/* $dest
+}