summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordemize2017-05-22 19:01:42 +0000
committersvntogit2017-05-22 19:01:42 +0000
commit482f1321c9385080830fe7b7b5a3036b8eef62f8 (patch)
tree64dcf358250d5047b433b30a9cddab84fbd11afa
parentce77307bcebc621780b3d7989016444971928f16 (diff)
downloadaur-482f1321c9385080830fe7b7b5a3036b8eef62f8.tar.gz
upgpkg: python-sphinx 1.6.1-1
git-svn-id: file:///srv/repos/svn-community/svn@229308 9fca08f4-af9d-4005-b8df-a31f2cc04f65
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
2 files changed, 14 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6613ae165c13..a4f7a7d9a979 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = python-sphinx
- pkgver = 1.5.5
+ pkgver = 1.6.1
pkgrel = 1
url = http://sphinx.pocoo.org/
arch = any
@@ -24,6 +24,8 @@ pkgbase = python-sphinx
checkdepends = python2-pytest
checkdepends = python-pytest
checkdepends = python2-enum34
+ checkdepends = python-sphinxcontrib-websupport
+ checkdepends = python2-sphinxcontrib-websupport
makedepends = python-setuptools
makedepends = python-docutils
makedepends = python-jinja
@@ -36,8 +38,8 @@ pkgbase = python-sphinx
makedepends = python2-pygments
makedepends = python2-six
makedepends = python2-imagesize
- source = https://pypi.org/packages/source/S/Sphinx/Sphinx-1.5.5.tar.gz
- md5sums = f9581b3556df9722143c47290273bcf8
+ source = https://pypi.org/packages/source/S/Sphinx/Sphinx-1.6.1.tar.gz
+ md5sums = 26cb1cdca7aa4afc8c925d926b6268e7
pkgname = python-sphinx
pkgdesc = Python3 documentation generator
@@ -52,6 +54,7 @@ pkgname = python-sphinx
depends = python-imagesize
depends = python-requests
optdepends = texlive-latexextra: for generation of PDF documentation
+ optdepends = python-sphinxcontrib-websupport: Python API to easily integrate Sphinx documentation into Web applications
pkgname = python2-sphinx
pkgdesc = Python2 documentation generator
@@ -66,4 +69,5 @@ pkgname = python2-sphinx
depends = python2-imagesize
depends = python2-requests
optdepends = texlive-latexextra: for generation of PDF documentation
+ optdepends = python2-sphinxcontrib-websupport: Python API to easily integrate Sphinx documentation into Web applications
diff --git a/PKGBUILD b/PKGBUILD
index 71150f9d89d1..f0029a331210 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgbase=python-sphinx
pkgname=('python-sphinx' 'python2-sphinx')
-pkgver=1.5.5
+pkgver=1.6.1
pkgrel=1
arch=('any')
@@ -40,11 +40,12 @@ checkdepends=(
'python-requests' 'python2-requests'
'python2-pytest' 'python-pytest'
'python2-enum34'
+ 'python-sphinxcontrib-websupport' 'python2-sphinxcontrib-websupport'
)
source=("https://pypi.org/packages/source/S/Sphinx/Sphinx-$pkgver.tar.gz")
-md5sums=('f9581b3556df9722143c47290273bcf8')
+md5sums=('26cb1cdca7aa4afc8c925d926b6268e7')
prepare() {
# souce duplication is required because makefile modify source code
@@ -94,7 +95,8 @@ package_python-sphinx() {
'python-imagesize'
'python-requests'
)
- optdepends=('texlive-latexextra: for generation of PDF documentation')
+ optdepends=('texlive-latexextra: for generation of PDF documentation'
+ 'python-sphinxcontrib-websupport: Python API to easily integrate Sphinx documentation into Web applications')
cd Sphinx-$pkgver
python setup.py install --root="$pkgdir" --optimize=1
@@ -116,7 +118,8 @@ package_python2-sphinx() {
'python2-imagesize'
'python2-requests'
)
- optdepends=('texlive-latexextra: for generation of PDF documentation')
+ optdepends=('texlive-latexextra: for generation of PDF documentation'
+ 'python2-sphinxcontrib-websupport: Python API to easily integrate Sphinx documentation into Web applications')
cd Sphinx-${pkgver}2
python2 setup.py install --root="$pkgdir" --optimize=1