summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordemize2017-05-23 21:53:04 +0000
committersvntogit2017-05-23 21:53:04 +0000
commitfd2950b3db3265fe7220b0ba043b3639449a29c1 (patch)
treea3d36d958f6102a6ee4f1fec8f7399fcf88fa170
parent462d05fc7088f25161a052093746f5f8517bc986 (diff)
downloadaur-fd2950b3db3265fe7220b0ba043b3639449a29c1.tar.gz
upgpkg: python-sphinx 1.6.1-3
git-svn-id: file:///srv/repos/svn-community/svn@229859 9fca08f4-af9d-4005-b8df-a31f2cc04f65
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD32
-rw-r--r--fix-broken-latex-testcase.patch40
-rw-r--r--typing-module-py35+.patch30
4 files changed, 98 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4c6039b54d8b..87ec8f469636 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-sphinx
pkgver = 1.6.1
- pkgrel = 2
+ pkgrel = 3
url = http://sphinx.pocoo.org/
arch = any
license = BSD
@@ -46,8 +46,13 @@ pkgbase = python-sphinx
makedepends = python2-sphinxcontrib-websupport
makedepends = python2-sqlalchemy
makedepends = python2-whoosh
+ makedepends = python2-typing
source = https://pypi.org/packages/source/S/Sphinx/Sphinx-1.6.1.tar.gz
+ source = typing-module-py35+.patch
+ source = fix-broken-latex-testcase.patch
md5sums = 26cb1cdca7aa4afc8c925d926b6268e7
+ md5sums = 7e9371d2bbae0a790cb2ba9200979803
+ md5sums = 7ec2270be8902c2351f9f4a8c9a33f26
pkgname = python-sphinx
pkgdesc = Python3 documentation generator
@@ -82,6 +87,7 @@ pkgname = python2-sphinx
depends = python2-sphinxcontrib-websupport
depends = python2-sqlalchemy
depends = python2-whoosh
+ depends = python2-typing
optdepends = texlive-latexextra: for generation of PDF documentation
optdepends = imagemagick: ext.imageconverter
diff --git a/PKGBUILD b/PKGBUILD
index b6192e7d8865..adb72dda7a35 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgbase=python-sphinx
pkgname=('python-sphinx' 'python2-sphinx')
pkgver=1.6.1
-pkgrel=2
+pkgrel=3
arch=('any')
url='http://sphinx.pocoo.org/'
@@ -32,6 +32,7 @@ makedepends=(
'python2-sphinxcontrib-websupport'
'python2-sqlalchemy'
'python2-whoosh'
+ 'python2-typing'
)
checkdepends=(
@@ -50,11 +51,19 @@ checkdepends=(
'imagemagick' 'librsvg'
)
-source=("https://pypi.org/packages/source/S/Sphinx/Sphinx-$pkgver.tar.gz")
+source=("https://pypi.org/packages/source/S/Sphinx/Sphinx-$pkgver.tar.gz"
+ "typing-module-py35+.patch"
+ "fix-broken-latex-testcase.patch")
-md5sums=('26cb1cdca7aa4afc8c925d926b6268e7')
+md5sums=('26cb1cdca7aa4afc8c925d926b6268e7'
+ '7e9371d2bbae0a790cb2ba9200979803'
+ '7ec2270be8902c2351f9f4a8c9a33f26')
prepare() {
+ (cd Sphinx-$pkgver
+ patch -p1 <"$srcdir"/fix-broken-latex-testcase.patch
+ patch -p1 <"$srcdir"/typing-module-py35+.patch)
+
# souce duplication is required because makefile modify source code
# setyp.py --build tricks don't works well
cp -a Sphinx-$pkgver Sphinx-${pkgver}2
@@ -77,15 +86,15 @@ build() {
}
check() {
-# msg2 'Python 3 version'
-# cd "$srcdir"/Sphinx-$pkgver
-# LC_ALL="en_US.UTF-8" make PYTHON=python3 test
-# rm -r tests
-#
+ msg2 'Python 3 version'
+ cd "$srcdir"/Sphinx-$pkgver
+ LC_ALL="en_US.UTF-8" make PYTHON=python3 test
+ rm -r tests
+
msg2 'Python 2 version'
-# cd "$srcdir"/Sphinx-${pkgver}2
-# LC_ALL="en_US.UTF-8" make PYTHON=python2 test
-# rm -r tests
+ cd "$srcdir"/Sphinx-${pkgver}2
+ LC_ALL="en_US.UTF-8" make PYTHON=python2 test
+ rm -r tests
}
package_python-sphinx() {
@@ -130,6 +139,7 @@ package_python2-sphinx() {
'python2-sphinxcontrib-websupport'
'python2-sqlalchemy'
'python2-whoosh'
+ 'python2-typing'
)
optdepends=('texlive-latexextra: for generation of PDF documentation'
'imagemagick: ext.imageconverter')
diff --git a/fix-broken-latex-testcase.patch b/fix-broken-latex-testcase.patch
new file mode 100644
index 000000000000..a5d94cf31923
--- /dev/null
+++ b/fix-broken-latex-testcase.patch
@@ -0,0 +1,40 @@
+From dd3b100925194b4c8e411f0064c1d049538b95bf Mon Sep 17 00:00:00 2001
+From: Takeshi KOMIYA <i.tkomiya@gmail.com>
+Date: Wed, 17 May 2017 00:03:39 +0900
+Subject: [PATCH] Follow translations
+
+---
+ tests/test_build_latex.py | 14 +++++++-------
+ 1 file changed, 7 insertions(+), 7 deletions(-)
+
+diff --git a/tests/test_build_latex.py b/tests/test_build_latex.py
+index 4efe70eda..81522a365 100644
+--- a/tests/test_build_latex.py
++++ b/tests/test_build_latex.py
+@@ -310,19 +310,19 @@ def test_numref_with_language_ja(app, status, warning):
+ print(result)
+ print(status.getvalue())
+ print(warning.getvalue())
+- assert u'\\renewcommand{\\figurename}{\u56f3}' in result
+- assert '\\renewcommand{\\tablename}{TABLE}' in result
+- assert '\\renewcommand{\\literalblockname}{LIST}' in result
++ assert u'\\renewcommand{\\figurename}{\u56f3}' in result # 図
++ assert u'\\renewcommand{\\tablename}{\u8868}' in result # 表
++ assert u'\\renewcommand{\\literalblockname}{\u30ea\u30b9\u30c8}' in result # リスト
+ assert (u'\\hyperref[\\detokenize{index:fig1}]'
+ u'{\u56f3 \\ref{\\detokenize{index:fig1}}}') in result
+ assert ('\\hyperref[\\detokenize{baz:fig22}]'
+ '{Figure\\ref{\\detokenize{baz:fig22}}}') in result
+- assert ('\\hyperref[\\detokenize{index:table-1}]'
+- '{TABLE \\ref{\\detokenize{index:table-1}}}') in result
++ assert (u'\\hyperref[\\detokenize{index:table-1}]'
++ u'{\u8868 \\ref{\\detokenize{index:table-1}}}') in result
+ assert ('\\hyperref[\\detokenize{baz:table22}]'
+ '{Table:\\ref{\\detokenize{baz:table22}}}') in result
+- assert ('\\hyperref[\\detokenize{index:code-1}]'
+- '{LIST \\ref{\\detokenize{index:code-1}}}') in result
++ assert (u'\\hyperref[\\detokenize{index:code-1}]'
++ u'{\u30ea\u30b9\u30c8 \\ref{\\detokenize{index:code-1}}}') in result
+ assert ('\\hyperref[\\detokenize{baz:code22}]'
+ '{Code-\\ref{\\detokenize{baz:code22}}}') in result
+ assert (u'\\hyperref[\\detokenize{foo:foo}]'
diff --git a/typing-module-py35+.patch b/typing-module-py35+.patch
new file mode 100644
index 000000000000..fec7edd11276
--- /dev/null
+++ b/typing-module-py35+.patch
@@ -0,0 +1,30 @@
+From 34346a8ac129047c8ba345562a78c74a9bae8096 Mon Sep 17 00:00:00 2001
+From: Julien Schueller <schueller@phimeca.com>
+Date: Tue, 23 May 2017 09:33:45 +0200
+Subject: [PATCH] Do not require typing module for python>=3.5
+
+pkg_resources.DistributionNotFound: The 'typing' distribution was not found and is required by Sphinx
+---
+ setup.py | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index 95bb3778f..4544ca3b0 100644
+--- a/setup.py
++++ b/setup.py
+@@ -51,10 +51,14 @@
+ 'alabaster>=0.7,<0.8',
+ 'imagesize',
+ 'requests>=2.0.0',
+- 'typing',
+ 'setuptools',
+ 'sphinxcontrib-websupport',
+ ]
++
++# this is a backport to versions older than 3.5
++if sys.version_info < (3, 5):
++ requires.append('typing')
++
+ extras_require = {
+ # Environment Marker works for wheel 0.24 or later
+ ':sys_platform=="win32"': [