summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2024-05-23 21:54:17 +0800
committerUniversebenzene2024-05-23 21:54:17 +0800
commit840c490f285e1184215d32d3e96866bb51fb8a0d (patch)
treeedfce3e669d7e66e10c94d6fb2f5adc44b3bf9e4
parent34d6b2e34864e84b3ddafb9edb648cd3b1f3448f (diff)
downloadaur-python-sphinx_design.tar.gz
Update to version 0.6.0
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD14
2 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 92a1019683cf..e040fe9fcf76 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-sphinx_design
pkgdesc = A sphinx extension for designing beautiful, screen-size responsive web components
- pkgver = 0.5.0
+ pkgver = 0.6.0
pkgrel = 1
url = https://sphinx-design.readthedocs.io
arch = any
@@ -11,19 +11,19 @@ pkgbase = python-sphinx_design
makedepends = python-build
makedepends = python-installer
makedepends = python-myst-parser
- source = sphinx-design-0.5.0.tar.gz::https://github.com/executablebooks/sphinx-design/archive/refs/tags/v0.5.0.tar.gz
+ source = sphinx-design-0.6.0.tar.gz::https://github.com/executablebooks/sphinx-design/archive/refs/tags/v0.6.0.tar.gz
source = Makefile
- md5sums = a127b4dc73893156687c2dcaab77ae7d
+ md5sums = 62bf1abf18cd5294c39182b4d719bbb1
md5sums = a6aa4bc42b138d75f938065a0994c3e1
pkgname = python-sphinx_design
depends = python-sphinx
- optdepends = python-pre-commit: code_style
+ optdepends = pre-commit: code-style
optdepends = python-myst-parser: rtd
- optdepends = python-sphinx-furo: theme_furo
- optdepends = python-sphinx_rtd_theme: theme_rtd
- optdepends = python-sphinx-book-theme: theme_sbt
- optdepends = python-pydata-sphinx-theme: theme_pydata
+ optdepends = python-sphinx-furo: theme-furo
+ optdepends = python-sphinx_rtd_theme: theme-rtd
+ optdepends = python-sphinx-book-theme: theme-sbt
+ optdepends = python-pydata-sphinx-theme: theme-pydata
optdepends = python-sphinx_design-doc: Documentation for sphinx_design
pkgname = python-sphinx_design-doc
diff --git a/PKGBUILD b/PKGBUILD
index ef6eabf347bd..d1bb09f4f0e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgbase=python-sphinx_design
_pname=${pkgbase#python-}
_pyname=${_pname/_/-}
pkgname=("python-${_pname}" "python-${_pname}-doc")
-pkgver=0.5.0
+pkgver=0.6.0
pkgrel=1
pkgdesc="A sphinx extension for designing beautiful, screen-size responsive web components"
arch=('any')
@@ -20,7 +20,7 @@ checkdepends=('python-pytest-regressions') # myst-parser already in makedepends
#source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pname}/${_pname}-${pkgver}.tar.gz")
source=("${_pyname}-${pkgver}.tar.gz::https://github.com/executablebooks/sphinx-design/archive/refs/tags/v${pkgver}.tar.gz"
'Makefile')
-md5sums=('a127b4dc73893156687c2dcaab77ae7d'
+md5sums=('62bf1abf18cd5294c39182b4d719bbb1'
'a6aa4bc42b138d75f938065a0994c3e1')
prepare() {
@@ -48,12 +48,12 @@ check() {
package_python-sphinx_design() {
depends=('python-sphinx')
- optdepends=('python-pre-commit: code_style'
+ optdepends=('pre-commit: code-style'
'python-myst-parser: rtd'
- 'python-sphinx-furo: theme_furo'
- 'python-sphinx_rtd_theme: theme_rtd'
- 'python-sphinx-book-theme: theme_sbt'
- 'python-pydata-sphinx-theme: theme_pydata'
+ 'python-sphinx-furo: theme-furo'
+ 'python-sphinx_rtd_theme: theme-rtd'
+ 'python-sphinx-book-theme: theme-sbt'
+ 'python-pydata-sphinx-theme: theme-pydata'
'python-sphinx_design-doc: Documentation for sphinx_design')
cd ${srcdir}/${_pyname}-${pkgver}