summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2023-07-28 12:40:43 +0800
committerUniversebenzene2023-07-28 12:40:43 +0800
commit399d9b9bfa80f263b1b4507c8bac1f4843e24fb4 (patch)
tree8d496d2ea4f02938ccada9de21d03d1e8a33774d
parent863507383d962731a94126f33d2fd20c483492fb (diff)
downloadaur-399d9b9bfa80f263b1b4507c8bac1f4843e24fb4.tar.gz
Update to version 0.5.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
2 files changed, 15 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b905b7de301a..cb5c86076304 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-sphinx_design
pkgdesc = A sphinx extension for designing beautiful, screen-size responsive web components
- pkgver = 0.4.1
+ pkgver = 0.5.0
pkgrel = 1
url = https://sphinx-design.readthedocs.io
arch = any
@@ -11,15 +11,19 @@ pkgbase = python-sphinx_design
makedepends = python-build
makedepends = python-installer
makedepends = python-myst-parser
- source = sphinx-design-0.4.1.tar.gz::https://github.com/executablebooks/sphinx-design/archive/refs/tags/v0.4.1.tar.gz
+ source = sphinx-design-0.5.0.tar.gz::https://github.com/executablebooks/sphinx-design/archive/refs/tags/v0.5.0.tar.gz
source = Makefile
- md5sums = 66700d7b1cb6fcd93215c7b29913b740
+ md5sums = a127b4dc73893156687c2dcaab77ae7d
md5sums = a6aa4bc42b138d75f938065a0994c3e1
pkgname = python-sphinx_design
depends = python-sphinx
optdepends = python-pre-commit: code_style
optdepends = python-myst-parser: rtd
+ optdepends = python-sphinx-fure: theme_furo
+ optdepends = python-sphinx_rtd_theme: theme_rtd
+ optdepends = python-sphinx-book-theme: theme_sbt
+ optdepends = python-pydata-sphinx-theme: theme_pydata
optdepends = python-sphinx_design-doc: Documentation for sphinx_design
pkgname = python-sphinx_design-doc
diff --git a/PKGBUILD b/PKGBUILD
index 1d205c529c77..0fa9c437d068 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgbase=python-sphinx_design
_pname=${pkgbase#python-}
_pyname=${_pname/_/-}
pkgname=("python-${_pname}" "python-${_pname}-doc")
-pkgver=0.4.1
+pkgver=0.5.0
pkgrel=1
pkgdesc="A sphinx extension for designing beautiful, screen-size responsive web components"
arch=('any')
@@ -17,9 +17,10 @@ makedepends=('python-flit-core'
'python-myst-parser') # sphinx required by myst-parser
checkdepends=('python-pytest-regressions') # myst-parser already in makedepends
#source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
+#source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pname}/${_pname}-${pkgver}.tar.gz")
source=("${_pyname}-${pkgver}.tar.gz::https://github.com/executablebooks/sphinx-design/archive/refs/tags/v${pkgver}.tar.gz"
'Makefile')
-md5sums=('66700d7b1cb6fcd93215c7b29913b740'
+md5sums=('a127b4dc73893156687c2dcaab77ae7d'
'a6aa4bc42b138d75f938065a0994c3e1')
prepare() {
@@ -41,7 +42,7 @@ build() {
check() {
cd ${srcdir}/${_pyname}-${pkgver}
- pytest || warning "Tests failed" # -vv --color=yes
+ pytest || warning "Tests failed" # -vv -l -ra --color=yes -o console_output_style=count
# nosetests #|| warning "Tests failed"
}
@@ -49,6 +50,10 @@ package_python-sphinx_design() {
depends=('python-sphinx')
optdepends=('python-pre-commit: code_style'
'python-myst-parser: rtd'
+ 'python-sphinx-fure: theme_furo'
+ 'python-sphinx_rtd_theme: theme_rtd'
+ 'python-sphinx-book-theme: theme_sbt'
+ 'python-pydata-sphinx-theme: theme_pydata'
'python-sphinx_design-doc: Documentation for sphinx_design')
cd ${srcdir}/${_pyname}-${pkgver}