summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2023-04-13 18:32:46 +0800
committerUniversebenzene2023-04-13 18:32:46 +0800
commit863507383d962731a94126f33d2fd20c483492fb (patch)
treee094dcf57c8bf7ca8e47ce16fd633cbab357e79f
parent089f28befaad5cb182878f16e157acd60c9e6820 (diff)
downloadaur-863507383d962731a94126f33d2fd20c483492fb.tar.gz
Update to version 0.4.1
-rw-r--r--.SRCINFO14
-rw-r--r--Makefile134
-rw-r--r--PKGBUILD53
3 files changed, 176 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc000f680014..b905b7de301a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,26 @@
pkgbase = python-sphinx_design
pkgdesc = A sphinx extension for designing beautiful, screen-size responsive web components
- pkgver = 0.3.0
+ pkgver = 0.4.1
pkgrel = 1
url = https://sphinx-design.readthedocs.io
arch = any
license = MIT
- checkdepends = python-nose
+ checkdepends = python-pytest-regressions
makedepends = python-flit-core
makedepends = python-wheel
makedepends = python-build
makedepends = python-installer
- source = https://files.pythonhosted.org/packages/source/s/sphinx_design/sphinx_design-0.3.0.tar.gz
- md5sums = 8283e2917f9bf3b1ab5688deb6a1aaa5
+ makedepends = python-myst-parser
+ source = sphinx-design-0.4.1.tar.gz::https://github.com/executablebooks/sphinx-design/archive/refs/tags/v0.4.1.tar.gz
+ source = Makefile
+ md5sums = 66700d7b1cb6fcd93215c7b29913b740
+ md5sums = a6aa4bc42b138d75f938065a0994c3e1
pkgname = python-sphinx_design
depends = python-sphinx
optdepends = python-pre-commit: code_style
optdepends = python-myst-parser: rtd
optdepends = python-sphinx_design-doc: Documentation for sphinx_design
+
+pkgname = python-sphinx_design-doc
+ pkgdesc = Documentation for sphinx_design
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..c7979506d6bf
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,134 @@
+# Makefile for Sphinx documentation
+#
+
+# You can set these variables from the command line.
+SPHINXOPTS =
+SPHINXBUILD = sphinx-build
+PAPER =
+BUILDDIR = _build
+
+# Internal variables.
+PAPEROPT_a4 = -D latex_paper_size=a4
+PAPEROPT_letter = -D latex_paper_size=letter
+ALLSPHINXOPTS = -d $(BUILDDIR)/doctrees $(PAPEROPT_$(PAPER)) $(SPHINXOPTS) .
+
+.PHONY: help clean html dirhtml singlehtml pickle json htmlhelp qthelp devhelp epub latex latexpdf text man changes linkcheck doctest
+
+#This is needed with git because git doesn't create a dir if it's empty
+$(shell [ -d "_static" ] || mkdir -p _static)
+
+help:
+ @echo "Please use \`make <target>' where <target> is one of"
+ @echo " html to make standalone HTML files"
+ @echo " dirhtml to make HTML files named index.html in directories"
+ @echo " singlehtml to make a single large HTML file"
+ @echo " pickle to make pickle files"
+ @echo " json to make JSON files"
+ @echo " htmlhelp to make HTML files and a HTML help project"
+ @echo " qthelp to make HTML files and a qthelp project"
+ @echo " devhelp to make HTML files and a Devhelp project"
+ @echo " epub to make an epub"
+ @echo " latex to make LaTeX files, you can set PAPER=a4 or PAPER=letter"
+ @echo " latexpdf to make LaTeX files and run them through pdflatex"
+ @echo " text to make text files"
+ @echo " man to make manual pages"
+ @echo " changes to make an overview of all changed/added/deprecated items"
+ @echo " linkcheck to check all external links for integrity"
+ @echo " doctest to run all doctests embedded in the documentation (if enabled)"
+
+clean:
+ -rm -rf $(BUILDDIR)
+ -rm -rf api
+
+html:
+ $(SPHINXBUILD) -b html $(ALLSPHINXOPTS) $(BUILDDIR)/html
+ @echo
+ @echo "Build finished. The HTML pages are in $(BUILDDIR)/html."
+
+dirhtml:
+ $(SPHINXBUILD) -b dirhtml $(ALLSPHINXOPTS) $(BUILDDIR)/dirhtml
+ @echo
+ @echo "Build finished. The HTML pages are in $(BUILDDIR)/dirhtml."
+
+singlehtml:
+ $(SPHINXBUILD) -b singlehtml $(ALLSPHINXOPTS) $(BUILDDIR)/singlehtml
+ @echo
+ @echo "Build finished. The HTML page is in $(BUILDDIR)/singlehtml."
+
+pickle:
+ $(SPHINXBUILD) -b pickle $(ALLSPHINXOPTS) $(BUILDDIR)/pickle
+ @echo
+ @echo "Build finished; now you can process the pickle files."
+
+json:
+ $(SPHINXBUILD) -b json $(ALLSPHINXOPTS) $(BUILDDIR)/json
+ @echo
+ @echo "Build finished; now you can process the JSON files."
+
+htmlhelp:
+ $(SPHINXBUILD) -b htmlhelp $(ALLSPHINXOPTS) $(BUILDDIR)/htmlhelp
+ @echo
+ @echo "Build finished; now you can run HTML Help Workshop with the" \
+ ".hhp project file in $(BUILDDIR)/htmlhelp."
+
+qthelp:
+ $(SPHINXBUILD) -b qthelp $(ALLSPHINXOPTS) $(BUILDDIR)/qthelp
+ @echo
+ @echo "Build finished; now you can run "qcollectiongenerator" with the" \
+ ".qhcp project file in $(BUILDDIR)/qthelp, like this:"
+ @echo "# qcollectiongenerator $(BUILDDIR)/qthelp/Astropy.qhcp"
+ @echo "To view the help file:"
+ @echo "# assistant -collectionFile $(BUILDDIR)/qthelp/Astropy.qhc"
+
+devhelp:
+ $(SPHINXBUILD) -b devhelp $(ALLSPHINXOPTS) $(BUILDDIR)/devhelp
+ @echo
+ @echo "Build finished."
+ @echo "To view the help file:"
+ @echo "# mkdir -p $$HOME/.local/share/devhelp/Astropy"
+ @echo "# ln -s $(BUILDDIR)/devhelp $$HOME/.local/share/devhelp/Astropy"
+ @echo "# devhelp"
+
+epub:
+ $(SPHINXBUILD) -b epub $(ALLSPHINXOPTS) $(BUILDDIR)/epub
+ @echo
+ @echo "Build finished. The epub file is in $(BUILDDIR)/epub."
+
+latex:
+ $(SPHINXBUILD) -b latex $(ALLSPHINXOPTS) $(BUILDDIR)/latex
+ @echo
+ @echo "Build finished; the LaTeX files are in $(BUILDDIR)/latex."
+ @echo "Run \`make' in that directory to run these through (pdf)latex" \
+ "(use \`make latexpdf' here to do that automatically)."
+
+latexpdf:
+ $(SPHINXBUILD) -b latex $(ALLSPHINXOPTS) $(BUILDDIR)/latex
+ @echo "Running LaTeX files through pdflatex..."
+ make -C $(BUILDDIR)/latex all-pdf
+ @echo "pdflatex finished; the PDF files are in $(BUILDDIR)/latex."
+
+text:
+ $(SPHINXBUILD) -b text $(ALLSPHINXOPTS) $(BUILDDIR)/text
+ @echo
+ @echo "Build finished. The text files are in $(BUILDDIR)/text."
+
+man:
+ $(SPHINXBUILD) -b man $(ALLSPHINXOPTS) $(BUILDDIR)/man
+ @echo
+ @echo "Build finished. The manual pages are in $(BUILDDIR)/man."
+
+changes:
+ $(SPHINXBUILD) -b changes $(ALLSPHINXOPTS) $(BUILDDIR)/changes
+ @echo
+ @echo "The overview file is in $(BUILDDIR)/changes."
+
+linkcheck:
+ $(SPHINXBUILD) -b linkcheck $(ALLSPHINXOPTS) $(BUILDDIR)/linkcheck
+ @echo
+ @echo "Link check complete; look for any errors in the above output " \
+ "or in $(BUILDDIR)/linkcheck/output.txt."
+
+doctest:
+ $(SPHINXBUILD) -b doctest $(ALLSPHINXOPTS) $(BUILDDIR)/doctest
+ @echo "Testing of doctests in the sources finished, look at the " \
+ "results in $(BUILDDIR)/doctest/output.txt."
diff --git a/PKGBUILD b/PKGBUILD
index fa993547e175..1d205c529c77 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
pkgbase=python-sphinx_design
-_pyname=${pkgbase#python-}
-pkgname=("python-${_pyname}")
-#"python-${_pyname}-doc")
-pkgver=0.3.0
+_pname=${pkgbase#python-}
+_pyname=${_pname/_/-}
+pkgname=("python-${_pname}" "python-${_pname}-doc")
+pkgver=0.4.1
pkgrel=1
pkgdesc="A sphinx extension for designing beautiful, screen-size responsive web components"
arch=('any')
@@ -13,25 +13,36 @@ license=('MIT')
makedepends=('python-flit-core'
'python-wheel'
'python-build'
- 'python-installer')
-checkdepends=('python-nose')
-source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('8283e2917f9bf3b1ab5688deb6a1aaa5')
+ 'python-installer'
+ 'python-myst-parser') # sphinx required by myst-parser
+checkdepends=('python-pytest-regressions') # myst-parser already in makedepends
+#source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
+source=("${_pyname}-${pkgver}.tar.gz::https://github.com/executablebooks/sphinx-design/archive/refs/tags/v${pkgver}.tar.gz"
+ 'Makefile')
+md5sums=('66700d7b1cb6fcd93215c7b29913b740'
+ 'a6aa4bc42b138d75f938065a0994c3e1')
+
+prepare() {
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+ ln -s ${srcdir}/Makefile docs
+}
build() {
cd ${srcdir}/${_pyname}-${pkgver}
python -m build --wheel --no-isolation
-# msg "Building Docs"
-# cd ${srcdir}/${_pyname}-${pkgver}/docs
-# PYTHONPATH="../build/lib" make html
+ msg "Building Docs"
+ mkdir -p dist/lib
+ bsdtar -xpf dist/${_pyname/-/_}-${pkgver}-py3-none-any.whl -C dist/lib
+ PYTHONPATH="../dist/lib" make -C docs html
}
check() {
cd ${srcdir}/${_pyname}-${pkgver}
-# pytest #|| warning "Tests failed"
- nosetests || warning "Tests failed"
+ pytest || warning "Tests failed" # -vv --color=yes
+# nosetests #|| warning "Tests failed"
}
package_python-sphinx_design() {
@@ -46,11 +57,11 @@ package_python-sphinx_design() {
python -m installer --destdir="${pkgdir}" dist/*.whl
}
-#package_python-sphinx_design-doc() {
-# pkgdesc="Documentation for sphinx_design"
-# cd ${srcdir}/${_pyname}-${pkgver}/build/sphinx
-#
-# install -D -m644 ../../LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
-# install -d -m755 "${pkgdir}/usr/share/doc/${pkgbase}"
-# cp -a html "${pkgdir}/usr/share/doc/${pkgbase}"
-#}
+package_python-sphinx_design-doc() {
+ pkgdesc="Documentation for sphinx_design"
+ cd ${srcdir}/${_pyname}-${pkgver}/docs/_build
+
+ install -D -m644 ../../LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -d -m755 "${pkgdir}/usr/share/doc/${pkgbase}"
+ cp -a html "${pkgdir}/usr/share/doc/${pkgbase}"
+}