summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2022-06-17 12:06:32 +0800
committerUniversebenzene2022-06-17 12:06:32 +0800
commit87d1febebc9d132e96f9ac2d29348dd6f545e958 (patch)
tree34672f5505dca5fdebcb40e9cfb6838a1d09f438
downloadaur-87d1febebc9d132e96f9ac2d29348dd6f545e958.tar.gz
Initial import 0.2.0
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD56
3 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..89a0f1416eff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python-sphinx_design
+ pkgdesc = A sphinx extension for designing beautiful, screen-size responsive web components
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://sphinx-design.readthedocs.io
+ arch = any
+ license = MIT
+ checkdepends = python-nose
+ makedepends = python-flit-core
+ makedepends = python-wheel
+ makedepends = python-build
+ makedepends = python-installer
+ source = https://files.pythonhosted.org/packages/source/s/sphinx_design/sphinx_design-0.2.0.tar.gz
+ md5sums = 118bdf14990a0420f6a27be69ef3de78
+
+pkgname = python-sphinx_design
+ depends = python-sphinx<6
+ optdepends = python-pre-commit: code_style
+ optdepends = python-myst-parser: rtd
+ optdepends = python-sphinx_design-doc: Documentation for sphinx_design
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e896dcd6056d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+src
+pkg
+*.src.tar.gz
+*.tar.gz
+*.tar.bz2
+*.part
+*.pkg.tar.*
+*.log
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..686810910775
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Astro Benzene <universebenzene at sina dot com>
+
+pkgbase=python-sphinx_design
+_pyname=${pkgbase#python-}
+pkgname=("python-${_pyname}")
+#"python-${_pyname}-doc")
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="A sphinx extension for designing beautiful, screen-size responsive web components"
+arch=('any')
+url="https://sphinx-design.readthedocs.io"
+license=('MIT')
+makedepends=('python-flit-core'
+ 'python-wheel'
+ 'python-build'
+ 'python-installer')
+checkdepends=('python-nose')
+source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
+md5sums=('118bdf14990a0420f6a27be69ef3de78')
+
+build() {
+ cd ${srcdir}/${_pyname}-${pkgver}
+ python -m build --wheel --no-isolation
+
+# msg "Building Docs"
+# cd ${srcdir}/${_pyname}-${pkgver}/docs
+# PYTHONPATH="../build/lib" make html
+}
+
+check() {
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+# pytest #|| warning "Tests failed"
+ nosetests || warning "Tests failed"
+}
+
+package_python-sphinx_design() {
+ depends=('python-sphinx<6')
+ optdepends=('python-pre-commit: code_style'
+ 'python-myst-parser: rtd'
+ 'python-sphinx_design-doc: Documentation for sphinx_design')
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+ install -D -m644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -D -m644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
+ python -m installer --destdir="${pkgdir}" dist/*.whl
+}
+
+#package_python-sphinx_design-doc() {
+# pkgdesc="Documentation for sphinx_design"
+# cd ${srcdir}/${_pyname}-${pkgver}/build/sphinx
+#
+# install -D -m644 ../../LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+# install -d -m755 "${pkgdir}/usr/share/doc/${pkgbase}"
+# cp -a html "${pkgdir}/usr/share/doc/${pkgbase}"
+#}