summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Northon2023-05-04 19:33:39 -0400
committerPatrick Northon2023-05-04 19:33:39 -0400
commitea279a32a35685862fae4d06cf4de29726521364 (patch)
tree42f0767165da023be398e6ce45036dd8a482659b
downloadaur-ea279a32a35685862fae4d06cf4de29726521364.tar.gz
Initial commit.
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD25
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a343cb481500
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-sphinx_rtd_dark_mode
+ pkgdesc = Adds a toggleable dark mode to the Read the Docs theme.
+ pkgver = 1.2.4
+ pkgrel = 1
+ url = https://github.com/MrDogeBro/sphinx_rtd_dark_mode
+ arch = any
+ license = MIT
+ makedepends = python-setuptools-scm
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ depends = python-sphinx_rtd_theme
+ source = python-sphinx_rtd_dark_mode-1.2.4.tar.gz::https://github.com/MrDogeBro/sphinx_rtd_dark_mode/archive/refs/tags/v1.2.4.tar.gz
+ b2sums = 7aa68205af0578b841d35e7d7ccc8278060eafa13a598889dde6e75c3b27f606ffd7eac0c4bcc946b7e83bd2099e83c5b212768f230cabfcc6a8a0248b8f8ebc
+
+pkgname = python-sphinx_rtd_dark_mode
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b7ae37f156dd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Patrick Northon <northon_patrick3@yahoo.ca>
+
+pkgname=python-sphinx_rtd_dark_mode
+pkgver=1.2.4
+pkgrel=1
+pkgdesc='Adds a toggleable dark mode to the Read the Docs theme.'
+arch=('any')
+url='https://github.com/MrDogeBro/sphinx_rtd_dark_mode'
+license=('MIT')
+depends=('python-sphinx_rtd_theme')
+makedepends=('python-setuptools-scm' 'python-build' 'python-installer' 'python-wheel')
+source=("${pkgname}-${pkgver}.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
+b2sums=('7aa68205af0578b841d35e7d7ccc8278060eafa13a598889dde6e75c3b27f606ffd7eac0c4bcc946b7e83bd2099e83c5b212768f230cabfcc6a8a0248b8f8ebc')
+_srcdir="sphinx_rtd_dark_mode-${pkgver}"
+
+build() {
+ cd "$_srcdir"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "$_srcdir"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm644 -t "$pkgdir"/usr/share/licenses/$pkgname LICENSE
+}