summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Wienke2021-01-03 12:37:06 +0100
committerJohannes Wienke2021-01-03 12:37:06 +0100
commit8a093ecd1f9f11002599da3199831201aa418b93 (patch)
tree834980829e2f1e0649a4cb8c41ef55674d7b779f
parent3713711849d95d37b59cbf4124c8fad6bda0c78e (diff)
downloadaur-8a093ecd1f9f11002599da3199831201aa418b93.tar.gz
Version bump to 0.19
This also drops support for Python 2 as no python2-sphinx package exists anymore.
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD25
2 files changed, 10 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2bba95e84240..f45a7933fa26 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,15 @@
pkgbase = python-sphinxcontrib-plantuml
pkgdesc = Sphinx 'plantuml' extension
- pkgver = 0.17
+ pkgver = 0.19
pkgrel = 1
url = https://pypi.python.org/pypi/sphinxcontrib-plantuml
arch = any
license = BSD
makedepends = python-setuptools
- makedepends = python2-setuptools
- source = https://files.pythonhosted.org/packages/source/s/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.17.tar.gz
- sha256sums = 1e388ea0c8bc933adecf438f5243857ca238050a107d2768e5ffb490bbb733d7
-
-pkgname = python-sphinxcontrib-plantuml
depends = plantuml
depends = python-sphinx
+ source = https://files.pythonhosted.org/packages/source/s/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.19.tar.gz
+ sha256sums = 98b9f02282907b0c5b7a93a446c4649909aaf5785d2da0dd263c8ad68e00e288
-pkgname = python2-sphinxcontrib-plantuml
- depends = plantuml
- depends = python2-sphinx
+pkgname = python-sphinxcontrib-plantuml
diff --git a/PKGBUILD b/PKGBUILD
index 57aa575b1086..0e6cc4966fe0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,22 @@
-pkgbase=python-sphinxcontrib-plantuml
-pkgname=(python-sphinxcontrib-plantuml python2-sphinxcontrib-plantuml)
+pkgname=python-sphinxcontrib-plantuml
_pyname=sphinxcontrib-plantuml
-pkgver=0.17
+pkgver=0.19
pkgrel=1
arch=(any)
pkgdesc="Sphinx 'plantuml' extension"
url='https://pypi.python.org/pypi/sphinxcontrib-plantuml'
license=('BSD')
-makedepends=(python-setuptools python2-setuptools)
+makedepends=(python-setuptools)
+depends=('plantuml' 'python-sphinx')
source=("https://files.pythonhosted.org/packages/source/s/${_pyname}/${_pyname}-${pkgver}.tar.gz")
+sha256sums=('98b9f02282907b0c5b7a93a446c4649909aaf5785d2da0dd263c8ad68e00e288')
build() {
- cp -r $_pyname-$pkgver $_pyname-$pkgver-py2
-
cd $_pyname-$pkgver
python setup.py build
-
- cd "$srcdir"/$_pyname-$pkgver-py2
- python2 setup.py build
}
-package_python-sphinxcontrib-plantuml() {
- depends=('plantuml' 'python-sphinx')
+package() {
cd $_pyname-${pkgver}
python setup.py install --root="$pkgdir" --optimize=1
}
-
-package_python2-sphinxcontrib-plantuml() {
- depends=('plantuml' 'python2-sphinx')
- cd $_pyname-${pkgver}-py2
- python2 setup.py install --root="$pkgdir" --optimize=1
-}
-
-sha256sums=('1e388ea0c8bc933adecf438f5243857ca238050a107d2768e5ffb490bbb733d7')