summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndré Klitzing2016-02-19 15:10:32 +0100
committerAndré Klitzing2016-02-19 15:10:32 +0100
commit8ee483ff611af469654992f64e561644b7dacb0e (patch)
tree99ef1bd626e852da287bb024129602d12cf18e26
downloadaur-8ee483ff611af469654992f64e561644b7dacb0e.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore9
-rw-r--r--PKGBUILD33
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1df773094413
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Fri Feb 19 14:10:10 UTC 2016
+pkgbase = python-sphinxcontrib-plantuml
+ pkgdesc = Sphinx 'plantuml' extension
+ pkgver = 0.6
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/sphinxcontrib-plantuml
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ source = https://pypi.python.org/packages/source/s/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.6.tar.gz
+ sha256sums = a88c5fa6ba5a4ed6150cde3cd1635e3c9fe7f17a99bf16777947dece59287072
+
+pkgname = python-sphinxcontrib-plantuml
+
+pkgname = python2-sphinxcontrib-plantuml
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ce9c71dbce23
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+*.src.tar.*
+*.pkg.tar.*
+*.orig
+*.rej
+*.swp
+*.part
+*.tar.gz
+src
+pkg
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..370da78f7e3a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+pkgbase=python-sphinxcontrib-plantuml
+pkgname=(python-sphinxcontrib-plantuml python2-sphinxcontrib-plantuml)
+_pyname=sphinxcontrib-plantuml
+pkgver=0.6
+pkgrel=1
+arch=(any)
+pkgdesc="Sphinx 'plantuml' extension"
+url='https://pypi.python.org/pypi/sphinxcontrib-plantuml'
+license=('BSD')
+makedepends=(python-setuptools python2-setuptools)
+source=("https://pypi.python.org/packages/source/s/${_pyname}/${_pyname}-${pkgver}.tar.gz")
+
+build() {
+ cp -r $_pyname-$pkgver $_pyname-$pkgver-py2
+
+ cd $_pyname-$pkgver
+ python setup.py build
+
+ cd "$srcdir"/$_pyname-$pkgver-py2
+ python2 setup.py build
+}
+
+package_python-sphinxcontrib-plantuml() {
+ cd $_pyname-${pkgver}
+ python setup.py install --root="$pkgdir" --optimize=1
+}
+
+package_python2-sphinxcontrib-plantuml() {
+ cd $_pyname-${pkgver}-py2
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}
+
+sha256sums=('a88c5fa6ba5a4ed6150cde3cd1635e3c9fe7f17a99bf16777947dece59287072')