summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Wienke2021-09-26 19:54:57 +0200
committerJohannes Wienke2021-09-26 19:59:58 +0200
commite8f0dd5fcbd81696ec0e11bc148bf1e0d7403c61 (patch)
tree498ea73fa5cd34a2e7226c9229727b6f7351ef1c
parent8b413c698be0f5675e44e53095365875e726cc5c (diff)
downloadaur-e8f0dd5fcbd81696ec0e11bc148bf1e0d7403c61.tar.gz
ci: add a Gitlab CI config
-rw-r--r--.gitlab-ci.yml52
1 files changed, 52 insertions, 0 deletions
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
new file mode 100644
index 000000000000..114fd56fde90
--- /dev/null
+++ b/.gitlab-ci.yml
@@ -0,0 +1,52 @@
+build:
+ stage: build
+ image:
+ name: countstarlight/makepkg:latest
+ entrypoint: [""]
+ before_script:
+ - yay -Syu --noconfirm
+ script:
+ - |
+ depends=()
+ makedepends=()
+ checkdepends=()
+ . ./PKGBUILD
+ deps=( "${depends[@]}" "${makedepends[@]}" "${checkdepends[@]}" )
+ (pacman --deptest "${deps[@]}" || true) | xargs yay -Sy --noconfirm
+ - makepkg -f
+ artifacts:
+ untracked: false
+ expire_in: 5 days
+ paths:
+ - '*.pkg.tar.zst'
+
+test:
+ stage: test
+ image:
+ name: countstarlight/makepkg:latest
+ entrypoint: [""]
+ script:
+ - yay -Syu --noconfirm
+ - yay --noconfirm -U *.pkg.tar.zst
+ - python -c "import sphinxcontrib.plantuml"
+
+deploy:
+ stage: deploy
+ image: bitnami/git:latest
+ rules:
+ - if: $CI_COMMIT_BRANCH == $CI_DEFAULT_BRANCH
+ variables:
+ GIT_DEPTH: "0"
+ before_script:
+ - mkdir -p ~/.ssh
+ - chmod 700 ~/.ssh
+
+ - ssh-keyscan aur.archlinux.org >> ~/.ssh/known_hosts
+ - chmod 644 ~/.ssh/known_hosts
+
+ - eval $(ssh-agent -s)
+ - echo "$SSH_PRIVATE_KEY" | tr -d '\r' | ssh-add -
+
+ script:
+ - git remote add aur ssh://aur@aur.archlinux.org/python-sphinxcontrib-plantuml.git
+ - git push aur origin/master:master