summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHyacinthe Cartiaux2016-09-05 00:39:30 +0200
committerHyacinthe Cartiaux2016-09-05 00:39:30 +0200
commit08eac618e8af2c937ae6c42920e94575e775238e (patch)
treee8a42d13e4939c9c24f753bf4f8e1dbea1204014
downloadaur-08eac618e8af2c937ae6c42920e94575e775238e.tar.gz
Import 0.8 from aur-mirror: https://github.com/aur-archive/sphinxcontrib-programoutput/
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD28
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1a5c12d43b7d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sun Sep 4 22:39:16 UTC 2016
+pkgbase = sphinxcontrib-programoutput
+ pkgdesc = Sphinx extension to include program output
+ pkgver = 0.8
+ pkgrel = 1
+ url = https://bitbucket.org/birkenfeld/sphinx-contrib
+ arch = any
+ license = BSD
+ makedepends = python
+ depends = python
+ depends = python-sphinx
+ provides = sphinxcontrib-programoutput
+ options = !emptydirs
+ source = https://pypi.python.org/packages/source/s/sphinxcontrib-programoutput/sphinxcontrib-programoutput-0.8.tar.gz
+ md5sums = bb0be17ef13f268378b2af51ff413c58
+
+pkgname = sphinxcontrib-programoutput
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..21d797145a16
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Josh VanderLinden <arch@cloudlery.com>
+pkgname=sphinxcontrib-programoutput
+pkgver=0.8
+pkgrel=1
+pkgdesc="Sphinx extension to include program output"
+arch=('any')
+url="https://bitbucket.org/birkenfeld/sphinx-contrib"
+license=('BSD')
+depends=('python' 'python-sphinx')
+makedepends=('python')
+provides=('sphinxcontrib-programoutput')
+options=(!emptydirs)
+source=(
+ "https://pypi.python.org/packages/source/s/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+)
+md5sums=('bb0be17ef13f268378b2af51ff413c58')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ python setup.py install --root="$pkgdir/" --optimize=1
+
+ [ $(command -v python2) ] && python2 setup.py install --root="$pkgdir/" --optimize=1
+
+ install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
+
+# vim:set ts=2 sw=2 et: