summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072019-03-13 17:44:45 +0100
committersL1pKn072019-03-13 17:44:45 +0100
commit3a64edb15b60bb01829ae45415a9cd2647cab2c8 (patch)
tree222679075ed3db7487ed8352ec7ac326c23f19ff
downloadaur-3a64edb15b60bb01829ae45415a9cd2647cab2c8.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD52
3 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..23d2879e2ded
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Wed Mar 13 16:44:45 UTC 2019
+pkgbase = python-sphinxcontrib-svg2pdfconverter
+ pkgdesc = Sphinx SVG to PDF converter extension
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/sephalon/sphinxcontrib-svg2pdfconverter
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ makedepends = python-sphinx
+ makedepends = python2-sphinx
+ optdepends = librsvg: Use librsvg engine
+ optdepends = inkscape: Use inkscape engine
+ source = https://github.com/missinglinkelectronics/sphinxcontrib-svg2pdfconverter/archive/v0.1.0.tar.gz
+ sha256sums = 3408cdbf76b7f871c0453ef9999ead4740f04f4f2f86a19b5afc5d05f01372cf
+
+pkgname = python-sphinxcontrib-svg2pdfconverter
+ depends = python-sphinx
+
+pkgname = python2-sphinxcontrib-svg2pdfconverter
+ depends = python2-sphinx
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7316f0b33ca6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+pkgbase=python-sphinxcontrib-svg2pdfconverter
+pkgname=('python-sphinxcontrib-svg2pdfconverter'
+ 'python2-sphinxcontrib-svg2pdfconverter'
+ )
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Sphinx SVG to PDF converter extension"
+arch=('any')
+url='https://github.com/sephalon/sphinxcontrib-svg2pdfconverter'
+license=('BSD')
+makedepends=('python-setuptools'
+ 'python2-setuptools'
+ 'python-sphinx'
+ 'python2-sphinx'
+ )
+optdepends=('librsvg: Use librsvg engine'
+ 'inkscape: Use inkscape engine'
+ )
+source=("https://github.com/missinglinkelectronics/sphinxcontrib-svg2pdfconverter/archive/v${pkgver}.tar.gz")
+sha256sums=('3408cdbf76b7f871c0453ef9999ead4740f04f4f2f86a19b5afc5d05f01372cf')
+
+prepare() {
+ cp -a sphinxcontrib-svg2pdfconverter-${pkgver}{,-py2}
+}
+
+build() {
+ cd "${srcdir}/sphinxcontrib-svg2pdfconverter-${pkgver}"
+ python setup.py build
+
+ cd "${srcdir}/sphinxcontrib-svg2pdfconverter-${pkgver}-py2"
+ python2 setup.py build
+}
+
+package_python-sphinxcontrib-svg2pdfconverter() {
+ depends=('python-sphinx')
+
+ cd "sphinxcontrib-svg2pdfconverter-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+
+ install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/License.txt"
+}
+
+package_python2-sphinxcontrib-svg2pdfconverter() {
+ depends=('python2-sphinx')
+
+ cd "sphinxcontrib-svg2pdfconverter-${pkgver}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+
+ install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/License.txt"
+}