summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072019-03-13 17:51:04 +0100
committersL1pKn072019-03-13 17:51:04 +0100
commitd92ebd90f195d17e74e65a734b31d52bf76a2e72 (patch)
tree1c7da83496647acbd4dc7e6754dba072e68902b6
parent3a64edb15b60bb01829ae45415a9cd2647cab2c8 (diff)
downloadaur-d92ebd90f195d17e74e65a734b31d52bf76a2e72.tar.gz
ops. seems is python3 only
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD31
2 files changed, 6 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 23d2879e2ded..d3a9765bcab5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Wed Mar 13 16:44:45 UTC 2019
+# Wed Mar 13 16:50:46 UTC 2019
pkgbase = python-sphinxcontrib-svg2pdfconverter
pkgdesc = Sphinx SVG to PDF converter extension
pkgver = 0.1.0
@@ -8,17 +8,11 @@ pkgbase = python-sphinxcontrib-svg2pdfconverter
arch = any
license = BSD
makedepends = python-setuptools
- makedepends = python2-setuptools
- makedepends = python-sphinx
- makedepends = python2-sphinx
+ depends = python-sphinx
optdepends = librsvg: Use librsvg engine
optdepends = inkscape: Use inkscape engine
source = https://github.com/missinglinkelectronics/sphinxcontrib-svg2pdfconverter/archive/v0.1.0.tar.gz
sha256sums = 3408cdbf76b7f871c0453ef9999ead4740f04f4f2f86a19b5afc5d05f01372cf
pkgname = python-sphinxcontrib-svg2pdfconverter
- depends = python-sphinx
-
-pkgname = python2-sphinxcontrib-svg2pdfconverter
- depends = python2-sphinx
diff --git a/PKGBUILD b/PKGBUILD
index 7316f0b33ca6..0f542b2b7e44 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,52 +1,29 @@
# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
-pkgbase=python-sphinxcontrib-svg2pdfconverter
-pkgname=('python-sphinxcontrib-svg2pdfconverter'
- 'python2-sphinxcontrib-svg2pdfconverter'
- )
+pkgname=python-sphinxcontrib-svg2pdfconverter
pkgver=0.1.0
pkgrel=1
pkgdesc="Sphinx SVG to PDF converter extension"
arch=('any')
url='https://github.com/sephalon/sphinxcontrib-svg2pdfconverter'
license=('BSD')
-makedepends=('python-setuptools'
- 'python2-setuptools'
- 'python-sphinx'
- 'python2-sphinx'
- )
+depends=('python-sphinx')
+makedepends=('python-setuptools')
optdepends=('librsvg: Use librsvg engine'
'inkscape: Use inkscape engine'
)
source=("https://github.com/missinglinkelectronics/sphinxcontrib-svg2pdfconverter/archive/v${pkgver}.tar.gz")
sha256sums=('3408cdbf76b7f871c0453ef9999ead4740f04f4f2f86a19b5afc5d05f01372cf')
-prepare() {
- cp -a sphinxcontrib-svg2pdfconverter-${pkgver}{,-py2}
-}
-
build() {
cd "${srcdir}/sphinxcontrib-svg2pdfconverter-${pkgver}"
python setup.py build
-
- cd "${srcdir}/sphinxcontrib-svg2pdfconverter-${pkgver}-py2"
- python2 setup.py build
}
-package_python-sphinxcontrib-svg2pdfconverter() {
- depends=('python-sphinx')
+package() {
cd "sphinxcontrib-svg2pdfconverter-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1
install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/License.txt"
}
-
-package_python2-sphinxcontrib-svg2pdfconverter() {
- depends=('python2-sphinx')
-
- cd "sphinxcontrib-svg2pdfconverter-${pkgver}"
- python2 setup.py install --root="${pkgdir}" --optimize=1
-
- install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/License.txt"
-}