summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072022-06-01 21:09:19 +0200
committersL1pKn072022-06-01 21:09:19 +0200
commitf2cd8e8bef1603a21310d942d8e74e6b59f6c3bb (patch)
treeaa2be61931dff1d2b1b54b7b20557e3ea6f4b4f6
parenta58a8d4754ee476f59d61845db31536639a93f5e (diff)
downloadaur-f2cd8e8bef1603a21310d942d8e74e6b59f6c3bb.tar.gz
Fix URL and switch build method to pip
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
2 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c164d5840ee9..07a768866a25 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,10 +2,10 @@ pkgbase = python-sphinxcontrib-svg2pdfconverter
pkgdesc = Sphinx SVG to PDF converter extension
pkgver = 1.2.0
pkgrel = 1
- url = https://github.com/sephalon/sphinxcontrib-svg2pdfconverter
+ url = https://github.com/missinglinkelectronics/sphinxcontrib-svg2pdfconverter
arch = any
license = BSD
- makedepends = python-setuptools
+ makedepends = python-packaging
depends = python-sphinx
optdepends = librsvg: Use librsvg engine
optdepends = inkscape: Use inkscape engine
diff --git a/PKGBUILD b/PKGBUILD
index e3dc2a61a297..e3b3edc111f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,10 +5,10 @@ pkgver=1.2.0
pkgrel=1
pkgdesc="Sphinx SVG to PDF converter extension"
arch=('any')
-url='https://github.com/sephalon/sphinxcontrib-svg2pdfconverter'
+url='https://github.com/missinglinkelectronics/sphinxcontrib-svg2pdfconverter'
license=('BSD')
depends=('python-sphinx')
-makedepends=('python-setuptools')
+makedepends=('python-packaging')
optdepends=('librsvg: Use librsvg engine'
'inkscape: Use inkscape engine'
)
@@ -17,13 +17,12 @@ sha256sums=('295a93bb4e81751e7a3fb63cbe4ead43f9341cd94fa8c65f606a2cf454b79c85')
build() {
cd "${srcdir}/sphinxcontrib-svg2pdfconverter-${pkgver}"
- python setup.py build
+ pip wheel --no-deps . -w dist
}
package() {
-
- cd "sphinxcontrib-svg2pdfconverter-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1
+ cd "${srcdir}/sphinxcontrib-svg2pdfconverter-${pkgver}"
+ pip install -I --root "${pkgdir}" --no-warn-script-location --no-deps dist/*.whl
install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/License.txt"
}