summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShane Stone2022-08-06 21:29:27 -0400
committerShane Stone2022-08-06 21:29:27 -0400
commit7b416cacbcfcb42db2668332aa66d8d3d3ba66ef (patch)
treee9c8458558772ea38b95b3c7c8d05630ff67b350
parentadb9010983b2fcc3f42525145042c713408ce23d (diff)
downloadaur-7b416cacbcfcb42db2668332aa66d8d3d3ba66ef.tar.gz
Change install from setup.py to python-build
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 28cf71be848f..08a1acb40c44 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,6 +6,8 @@ pkgbase = python-spiceypy
arch = any
license = MIT
makedepends = python-numpy
+ makedepends = python-build
+ makedepends = python-installer
depends = python-numpy
optdepends = python-pytest: testing
optdepends = python-pandas: testing
diff --git a/PKGBUILD b/PKGBUILD
index a8f838f64481..ee0752edaf26 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,17 +7,25 @@ pkgdesc="A Python wrapper for the NAIF C SPICE Toolkit (N66) written using ctype
arch=('any')
url="https://github.com/AndrewAnnex/SpiceyPy/"
license=('MIT')
-makedepends=('python-numpy')
+makedepends=('python-numpy' 'python-build' 'python-installer')
depends=('python-numpy')
optdepends=('python-pytest: testing' 'python-pandas: testing')
source=("$pkgname-$pkgver.tar.gz::https://github.com/andrewannex/spiceypy/archive/v$pkgver.tar.gz")
sha512sums=('9765be83df5d71a828a2a4d390feeb65ca2350d5965ccfdd876a44cd8e6d839b5c51340cd9a3537f0de330043f644e12e8904b5ac3f58f6f2fc74f2ea2742acf')
+build() {
+
+ cd SpiceyPy-$pkgver
+
+ python -m build --wheel --no-isolation
+
+}
+
package() {
cd SpiceyPy-$pkgver
- python setup.py install --root="$pkgdir" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE