summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShane Stone2018-01-03 23:59:05 -0700
committerShane Stone2018-01-03 23:59:05 -0700
commit8ebdc5a77327c44497f129a8a8be39050344c134 (patch)
tree5a1f83af71f86ff40dcdcd49eebc35125c089534
parentfadf1813735e721335329f599fe2fa92761869e0 (diff)
downloadaur-8ebdc5a77327c44497f129a8a8be39050344c134.tar.gz
Fix spice.so problem with explicit mv call.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 90a0e73da8c3..38b1971fe9f7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-spiceypy
pkgdesc = A Python wrapper for the NAIF C SPICE Toolkit (N66) written using ctypes.
pkgver = 2.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/AndrewAnnex/SpiceyPy
arch = any
license = MIT
@@ -14,6 +14,5 @@ pkgbase = python-spiceypy
pkgname = python-spiceypy
depends = python-six>=1.9.0
depends = python-numpy>=1.8.0
- depends = python-certifi>=2017.1.23
optdepends = python-pytest>=2.9.0: testing
diff --git a/PKGBUILD b/PKGBUILD
index 06fe6bcaedad..150df47da066 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=('python-spiceypy')
pkgver=2.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="A Python wrapper for the NAIF C SPICE Toolkit (N66) written using ctypes."
arch=('any')
url="https://github.com/AndrewAnnex/SpiceyPy"
@@ -19,12 +19,14 @@ build() {
}
package() {
- depends=('python-six>=1.9.0' 'python-numpy>=1.8.0' 'python-certifi>=2017.1.23')
+ depends=('python-six>=1.9.0' 'python-numpy>=1.8.0')
optdepends=('python-pytest>=2.9.0: testing')
cd SpiceyPy-$pkgver
python setup.py install --skip-build --root="$pkgdir" --optimize=1
+ mv -v $srcdir/SpiceyPy-$pkgver/spiceypy/utils/spice.so $pkgdir/usr/lib/python3*/site-packages/spiceypy/utils/
+
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}