summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShane Stone2017-10-23 19:58:39 -0700
committerShane Stone2017-10-23 19:58:39 -0700
commitba326379420796cdf076262207c4c9b2e4a8b6d2 (patch)
treee297af6fac94169ae793892c1317a864cfaa5d4f
parenta83d12497e923a1444fc16b20f3c9a4d31ce87af (diff)
downloadaur-ba326379420796cdf076262207c4c9b2e4a8b6d2.tar.gz
Split python-spiceypy and python2-spiceypy into completely different packages
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD32
2 files changed, 3 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5e2bf3117873..54e891d59c1b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,11 +6,8 @@ pkgbase = python-spiceypy
arch = any
license = MIT
makedepends = python-six>=1.9.0
- makedepends = python2-six>=1.9.0
makedepends = python-numpy>=1.8.0
- makedepends = python2-numpy>=1.8.0
makedepends = python-setuptools
- makedepends = python2-setuptools
source = https://github.com/andrewannex/spiceypy/archive/v2.0.0.tar.gz
md5sums = 7115d8c054e46b21c85863bd42de0a3d
@@ -19,8 +16,3 @@ pkgname = python-spiceypy
depends = python-numpy>=1.8.0
optdepends = python-pytest>=2.9.0: testing
-pkgname = python2-spiceypy
- depends = python2-six>=1.9.0
- depends = python2-numpy>=1.8.0
- optdepends = python2-pytest>=2.9.0: testing
-
diff --git a/PKGBUILD b/PKGBUILD
index 09f24fa180c1..95bc02a21d0b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,49 +1,23 @@
# $Id$
# Maintainer: Shane Stone <shanewstone at gmail>
-pkgbase=python-spiceypy
-pkgname=('python-spiceypy' 'python2-spiceypy')
+pkgname=('python-spiceypy')
pkgver=2.0.0
pkgrel=1
pkgdesc="A Python wrapper for the NAIF C SPICE Toolkit (N66) written using ctypes."
arch=('any')
url="https://github.com/AndrewAnnex/SpiceyPy"
license=('MIT')
-makedepends=('python-six>=1.9.0' 'python2-six>=1.9.0' 'python-numpy>=1.8.0' 'python2-numpy>=1.8.0' 'python-setuptools' 'python2-setuptools')
+makedepends=('python-six>=1.9.0' 'python-numpy>=1.8.0' 'python-setuptools')
source=("https://github.com/andrewannex/spiceypy/archive/v${pkgver}.tar.gz")
md5sums=('7115d8c054e46b21c85863bd42de0a3d')
-prepare() {
- cp -a SpiceyPy-$pkgver SpiceyPy-$pkgver-py2
- cd SpiceyPy-$pkgver-py2
-
- sed -e "s|#![ ]*/usr/bin/python[0-9]*$|#!/usr/bin/python2|" \
- -e "s|#![ ]*/usr/bin/env python[0-9]*$|#!/usr/bin/env python2|" \
- -e "s|#![ ]*/bin/env python[0-9]*$|#!/usr/bin/env python2|" \
- -i $(find . -name '*.py')
-}
-
build() {
- echo "Building Python2"
- cd SpiceyPy-$pkgver-py2
- python2 setup.py build
-
echo "Building Python3"
- cd ../SpiceyPy-$pkgver
+ cd SpiceyPy-$pkgver
python setup.py build
}
-package_python2-spiceypy() {
- depends=('python2-six>=1.9.0' 'python2-numpy>=1.8.0')
- optdepends=('python2-pytest>=2.9.0: testing')
-
- cd SpiceyPy-$pkgver-py2
-
- python2 setup.py install --skip-build --root="$pkgdir" --optimize=1
-
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
-}
-
package_python-spiceypy() {
depends=('python-six>=1.9.0' 'python-numpy>=1.8.0')
optdepends=('python-pytest>=2.9.0: testing')