summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzoorat2024-03-31 20:06:49 +0600
committerzoorat2024-03-31 20:06:49 +0600
commit07f0a08f21ce93b181b81fad34b9cc2f3debc9a8 (patch)
tree84ba04e239d4660e86acf8350b769c86a775302b
parent3667215f7a73b2b40cbe3dc769f72589344279a5 (diff)
downloadaur-07f0a08f21ce93b181b81fad34b9cc2f3debc9a8.tar.gz
mod: source is now pypi.io again
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eb5247c0effe..61b0f87bb3b5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-spotdl
pkgdesc = Download your Spotify playlists and songs along with album art and metadata (from YouTube if a match is found).
pkgver = 4.2.5
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/spotDL/spotify-downloader
arch = any
license = MIT
@@ -38,7 +38,7 @@ pkgbase = python-spotdl
options = strip
options = emptydirs
options = zipman
- source = https://github.com/spotDL/spotify-downloader/archive/refs/tags/v4.2.5.zip
- b2sums = fa0f99038c252c635e4c23dd14f8d528b443a4e5d2713c330c53a98495de02047f68e965e89183cdc40e3a413c79b0d94507b0ae428248a42b5fdfd8e2fa4081
+ source = https://pypi.io/packages/source/s/spotdl/spotdl-4.2.5.tar.gz
+ b2sums = e7b1ba0c7bebceb0d78ea0b4974b7a2a46612f03a3b3e457f8f996d68b9b23df0c199448956ad5f4398effbe5d59d51c43c310f998a8d4798d07bb89f6c51a5d
pkgname = python-spotdl
diff --git a/PKGBUILD b/PKGBUILD
index 96567dada5bb..23cd99283b7a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=python-spotdl
pkgver=4.2.5
-pkgrel=1
+pkgrel=2
pkgdesc='Download your Spotify playlists and songs along with album art and metadata (from YouTube if a match is found).'
arch=('any')
@@ -46,24 +46,24 @@ checkdepends=('python-pytest-asyncio')
provides=("$pkgname" 'spotdl')
options=(strip emptydirs zipman)
-# source=("https://pypi.io/packages/source/s/spotdl/spotdl-$pkgver.tar.gz")
-source=("https://github.com/spotDL/spotify-downloader/archive/refs/tags/v$pkgver.zip")
-b2sums=('fa0f99038c252c635e4c23dd14f8d528b443a4e5d2713c330c53a98495de02047f68e965e89183cdc40e3a413c79b0d94507b0ae428248a42b5fdfd8e2fa4081')
+source=("https://pypi.io/packages/source/s/spotdl/spotdl-$pkgver.tar.gz")
+# source=("https://github.com/spotDL/spotify-downloader/archive/refs/tags/v$pkgver.zip")
+b2sums=('e7b1ba0c7bebceb0d78ea0b4974b7a2a46612f03a3b3e457f8f996d68b9b23df0c199448956ad5f4398effbe5d59d51c43c310f998a8d4798d07bb89f6c51a5d')
# Document: https://wiki.archlinux.org/title/Python_package_guidelines
build() {
- cd spotify-downloader-$pkgver
+ cd spotdl-$pkgver
# https://github.com/python-poetry/poetry/issues/5547
python -m build --wheel --no-isolation
}
check() {
- cd spotify-downloader-$pkgver
+ cd spotdl-$pkgver
pytest || echo 'Tests failed!'
}
package() {
- cd spotify-downloader-$pkgver
+ cd spotdl-$pkgver
python -m installer --destdir="$pkgdir" dist/*.whl
install -vDm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}