summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Schumacher2021-03-16 09:51:20 +0100
committerTim Schumacher2021-03-16 09:51:20 +0100
commit6b921c802b79018a57f9002224ae2419154046d6 (patch)
treecc774a393ae8305c23f9e814a7d3f7ae40491917
parent32627809d98360fb9d347c0dfdf71230d31a3942 (diff)
downloadaur-6b921c802b79018a57f9002224ae2419154046d6.tar.gz
Update to 3.4.0
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dffe618e6568..26bcd85422b9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-spotdl
pkgdesc = Download songs from YouTube using Spotify song URLs or playlists with albumart and meta-tags.
- pkgver = 3.3.3
+ pkgver = 3.4.0
pkgrel = 1
url = https://github.com/spotDL/spotify-downloader
arch = any
@@ -14,8 +14,9 @@ pkgbase = python-spotdl
depends = python-mutagen
depends = python-ytmusicapi
depends = python-tqdm
- source = https://pypi.io/packages/source/s/spotdl/spotdl-3.3.3.tar.gz
- sha512sums = f8f4f5c98fe105728a0ff8513a09354eaa68a362d42f00c61cd0b7ece475072dac9d46444adeb501b9eba45f5260a1d16e971982539961a6dbc4468c2cca69e2
+ depends = python-beautifulsoup4
+ source = https://pypi.io/packages/source/s/spotdl/spotdl-3.4.0.tar.gz
+ sha512sums = 98d2c726f44cae48f605d16971c0487a547510f9afcbf669ec34ea7ce8df8b4b79dbeb7506d4e45a36df8bd5a55191bd0dde05fa75dc4ce62ec6d7881d0f91fa
pkgname = python-spotdl
diff --git a/PKGBUILD b/PKGBUILD
index 2ed5e46ee403..5d63c7ebaf17 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,22 @@
# Contributor: Gordian Edenhofer <gordian.edenhofer[at]yahoo[dot]de>
pkgname=python-spotdl
-pkgver=3.3.3
+pkgver=3.4.0
pkgrel=1
pkgdesc="Download songs from YouTube using Spotify song URLs or playlists with albumart and meta-tags."
arch=('any')
license=('MIT')
url="https://github.com/spotDL/spotify-downloader"
-depends=('python-setuptools' 'ffmpeg' 'python-spotipy' 'python-pytube' 'python-rich' 'python-rapidfuzz' 'python-mutagen' 'python-ytmusicapi' 'python-tqdm')
+depends=('python-setuptools' 'ffmpeg' 'python-spotipy' 'python-pytube' 'python-rich' 'python-rapidfuzz' 'python-mutagen' 'python-ytmusicapi' 'python-tqdm' 'python-beautifulsoup4')
source=("https://pypi.io/packages/source/s/spotdl/spotdl-$pkgver.tar.gz")
-sha512sums=('f8f4f5c98fe105728a0ff8513a09354eaa68a362d42f00c61cd0b7ece475072dac9d46444adeb501b9eba45f5260a1d16e971982539961a6dbc4468c2cca69e2')
+sha512sums=('98d2c726f44cae48f605d16971c0487a547510f9afcbf669ec34ea7ce8df8b4b79dbeb7506d4e45a36df8bd5a55191bd0dde05fa75dc4ce62ec6d7881d0f91fa')
build() {
cd spotdl-$pkgver
+
+ # bs4 is a metapackage, we have to install beautifulsoup4 instead
+ sed -i 's/bs4/beautifulsoup4/' setup.cfg
+
python setup.py build
}