summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzoorat2021-07-30 11:09:04 +0600
committerzoorat2021-07-30 11:09:04 +0600
commit932b8a7125b0810f824e81f1f240b8f7fa78e3d8 (patch)
tree85551bc16d68ce028abb43414ad69964d0d6b746
parent23d035f175d156ebdf2c9f3629c740bea17d79f0 (diff)
downloadaur-932b8a7125b0810f824e81f1f240b8f7fa78e3d8.tar.gz
updating to v3.7.1
Signed-off-by: zoorat <78788887+z00rat@users.noreply.github.com>
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD23
3 files changed, 26 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d9c1150740d3..ab72f730187f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-spotdl
- pkgdesc = Download songs from YouTube using Spotify song URLs or playlists with albumart and meta-tags.
- pkgver = 3.7.0
+ pkgdesc = Download your Spotify playlists and songs along with album art and metadata (from YouTube if a match is found).
+ pkgver = 3.7.1
pkgrel = 1
url = https://github.com/spotDL/spotify-downloader
arch = any
@@ -17,7 +17,7 @@ pkgbase = python-spotdl
depends = python-beautifulsoup4
depends = python-requests
depends = python-unidecode
- source = https://pypi.io/packages/source/s/spotdl/spotdl-3.7.0.tar.gz
- sha512sums = c2e2a30e0a8f712ca7bb96cf492ec6452f099d1455d807d4648e803990fc5aff3a209deeffc9c248fca4c0556e3182fd00e2c820565ef3fffacd035aa6a49ab3
+ source = https://pypi.io/packages/source/s/spotdl/spotdl-3.7.1.tar.gz
+ b2sums = 0a8ad178b73e8f7f1656daad58dd109466838a3c0ff50e6250b79f99488ee27083f3740fb1dacd483b0477b40f2b7e500d5a1ea8629f04b92990ee432e1983df
pkgname = python-spotdl
diff --git a/.gitignore b/.gitignore
index 43e40455076c..05c6d4d4c97b 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
-src/
-pkg/
-*.pkg.tar.xz
-*.tar.gz
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index 4a51314be1d7..b28d4ef1f4b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,30 @@
+# Maintainer: zoorat <zoorat [at] protonmail [dot] com>
# Contributor: Tim Schumacher <timschumi@gmx.de>
# Contributor: Felix Yan <felixonmars@archlinux.org>
# Contributor: Gordian Edenhofer <gordian.edenhofer[at]yahoo[dot]de>
pkgname=python-spotdl
-pkgver=3.7.0
+pkgver=3.7.1
pkgrel=1
-pkgdesc="Download songs from YouTube using Spotify song URLs or playlists with albumart and meta-tags."
+pkgdesc="Download your Spotify playlists and songs along with album art and metadata (from YouTube if a match is found)."
arch=('any')
-license=('MIT')
url="https://github.com/spotDL/spotify-downloader"
-depends=('python-setuptools' 'ffmpeg' 'python-spotipy' 'python-pytube' 'python-rich' 'python-rapidfuzz' 'python-mutagen' 'python-ytmusicapi' 'python-tqdm' 'python-beautifulsoup4' 'python-requests' 'python-unidecode')
+license=('MIT')
+depends=('python-setuptools'
+ 'ffmpeg'
+ 'python-spotipy'
+ 'python-pytube'
+ 'python-rich'
+ 'python-rapidfuzz'
+ 'python-mutagen'
+ 'python-ytmusicapi'
+ 'python-tqdm'
+ 'python-beautifulsoup4'
+ 'python-requests'
+ 'python-unidecode')
+
source=("https://pypi.io/packages/source/s/spotdl/spotdl-$pkgver.tar.gz")
-sha512sums=('c2e2a30e0a8f712ca7bb96cf492ec6452f099d1455d807d4648e803990fc5aff3a209deeffc9c248fca4c0556e3182fd00e2c820565ef3fffacd035aa6a49ab3')
+b2sums=('0a8ad178b73e8f7f1656daad58dd109466838a3c0ff50e6250b79f99488ee27083f3740fb1dacd483b0477b40f2b7e500d5a1ea8629f04b92990ee432e1983df')
build() {
cd spotdl-$pkgver