summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzoorat2023-11-12 21:51:51 +0600
committerzoorat2023-11-12 21:51:51 +0600
commitc7e10cd3edb1f926de543caab73b60fc3af3dd5d (patch)
treead6bc182bc37f574c6a3f9d6a4e4c69a88c81590
parent6fec14797a9b97321d771a3082a906e04ab339ed (diff)
downloadaur-c7e10cd3edb1f926de543caab73b60fc3af3dd5d.tar.gz
removing Makefile
-rw-r--r--Makefile82
1 files changed, 0 insertions, 82 deletions
diff --git a/Makefile b/Makefile
deleted file mode 100644
index c037a7da1139..000000000000
--- a/Makefile
+++ /dev/null
@@ -1,82 +0,0 @@
-##
-## This Makefile is just for the maintainer of this package
-## to easily keep this package up to date.
-## This won't have any effect on your build.
-##
-
-MAKEFLAGS += --warn-undefined-variables
-SHELL=/bin/bash
-
-REPO = $(shell grep url .SRCINFO | cut -d '=' -f 2 | tr -d '[:space:]')
-VERSION = $(shell grep pkgver .SRCINFO | cut -d '=' -f 2 | tr -d '[:space:]')
-TRASH = $(shell git check-ignore * | tr '\n' ' ')
-
-# DEFAULT
-all: clean sum build check pre clean
-
-# just build the package
-build:
- makepkg -sfr
-
-# build and install the package
-install:
- makepkg --install
-
-# update checksums
-sum:
- updpkgsums
-
-# check/lint
-check:
- @echo "shellcheck: "
- shellcheck -e SC2148 -e SC2034 -e SC2164 PKGBUILD || exit 0
-
- @echo "shell formate: "
- shfmt -d PKGBUILD || exit 0
-
- @echo "checking PKGBUILD: "
- namcap -i PKGBUILD
-
- @echo "checking build: "
- namcap -i *.pkg.*
-
-# clean up the mess
-clean:
-ifeq ($(strip $(TRASH)),)
- @echo "nothing to clear"
-else
- file $(TRASH)
- @echo -n "Are you sure? [Y/n] " && read ans && if [ $${ans:-'Y'} = 'Y' ]; then \
- trash-put -v $(TRASH) ; \
- exit 0 ; \
- fi
-endif
-
-# prepare for commit
-pre:
- shfmt -w PKGBUILD
- makepkg --printsrcinfo > .SRCINFO
-
- git diff
-
- git add PKGBUILD
- git add .SRCINFO
- git add .gitignore
- git add Makefile
-
-# commit with version bump message
-commit:
- $(eval VERSION := $(shell read -p "enter version (pkgver=$(VERSION)): " enter ; echo $${enter}))
- @echo "commit message: \"updating to v$(VERSION)\""
-
- @echo -n "Are you sure? [Y/n] " && read ans && if [ $${ans:-'Y'} = 'Y' ]; then \
- git diff --cached ; \
- exit 0 ; \
- fi
-
- @echo -n "Are you sure? [Y/n] " && read ans && if [ $${ans:-'Y'} = 'Y' ]; then \
- git commit -m "updating to v$(VERSION)" ; \
- exit 0 ; \
- fi
-
- @echo "recheck everything before pushing to AUR"