summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Schumacher2021-03-26 13:26:35 +0100
committerTim Schumacher2021-03-26 13:26:35 +0100
commitdb3d425e0f9922e63a292e5c8e6cb991b96ea632 (patch)
treea58e4e25b02f2602ce0a7118a5eb9e648d705d01
parent44929b4e8357a4394702fe5ebe52a00eb8944075 (diff)
downloadaur-db3d425e0f9922e63a292e5c8e6cb991b96ea632.tar.gz
Update to 3.5.0
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0a14f2e38432..3b1cfbf0d794 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-spotdl
pkgdesc = Download songs from YouTube using Spotify song URLs or playlists with albumart and meta-tags.
- pkgver = 3.4.2
+ pkgver = 3.5.0
pkgrel = 1
url = https://github.com/spotDL/spotify-downloader
arch = any
@@ -15,8 +15,9 @@ pkgbase = python-spotdl
depends = python-ytmusicapi
depends = python-tqdm
depends = python-beautifulsoup4
- source = https://pypi.io/packages/source/s/spotdl/spotdl-3.4.2.tar.gz
- sha512sums = a0399ef0200e99699206eb3a2ad5a94b81d8ae853c5824ff4913f0f0139e6307cc4744801c10963e4ea1fffb0992fd6c30b0712e3ba2ad921b592b1fb6ebda5a
+ depends = python-requests
+ source = https://pypi.io/packages/source/s/spotdl/spotdl-3.5.0.tar.gz
+ sha512sums = 2e3cd5a0dfeb1856a5d55c04a8183586fb689f837242233a6924804e4ce6294e091bca14b64896e0bd7eb6b8e58c593a9d1f44df546df651aa2b9271c8ca37f6
pkgname = python-spotdl
diff --git a/PKGBUILD b/PKGBUILD
index bbc408c6365b..7a7d62e0a311 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,19 @@
# Contributor: Gordian Edenhofer <gordian.edenhofer[at]yahoo[dot]de>
pkgname=python-spotdl
-pkgver=3.4.2
+pkgver=3.5.0
pkgrel=1
pkgdesc="Download songs from YouTube using Spotify song URLs or playlists with albumart and meta-tags."
arch=('any')
license=('MIT')
url="https://github.com/spotDL/spotify-downloader"
-depends=('python-setuptools' 'ffmpeg' 'python-spotipy' 'python-pytube' 'python-rich' 'python-rapidfuzz' 'python-mutagen' 'python-ytmusicapi' 'python-tqdm' 'python-beautifulsoup4')
+depends=('python-setuptools' 'ffmpeg' 'python-spotipy' 'python-pytube' 'python-rich' 'python-rapidfuzz' 'python-mutagen' 'python-ytmusicapi' 'python-tqdm' 'python-beautifulsoup4' 'python-requests')
source=("https://pypi.io/packages/source/s/spotdl/spotdl-$pkgver.tar.gz")
-sha512sums=('a0399ef0200e99699206eb3a2ad5a94b81d8ae853c5824ff4913f0f0139e6307cc4744801c10963e4ea1fffb0992fd6c30b0712e3ba2ad921b592b1fb6ebda5a')
+sha512sums=('2e3cd5a0dfeb1856a5d55c04a8183586fb689f837242233a6924804e4ce6294e091bca14b64896e0bd7eb6b8e58c593a9d1f44df546df651aa2b9271c8ca37f6')
build() {
cd spotdl-$pkgver
- # bs4 is a metapackage, we have to install beautifulsoup4 instead
- sed -i 's/bs4/beautifulsoup4/' setup.cfg
-
python setup.py build
}