summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzoorat2021-10-24 12:01:36 +0600
committerzoorat2021-10-24 12:01:36 +0600
commitfead31cc49f9354aa157c4d1647596cd8498fe73 (patch)
treee0040c6ba21f845386736e35ad660ba370971ca9
parenta722b42cc134e9394e4f33b82dae69689b3f711b (diff)
downloadaur-fead31cc49f9354aa157c4d1647596cd8498fe73.tar.gz
updating to v3.9.0
Signed-off-by: zoorat <78788887+z00rat@users.noreply.github.com>
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--spotdl.install29
3 files changed, 17 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 47aa3a51b320..5a7078a3da60 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-spotdl
pkgdesc = Download your Spotify playlists and songs along with album art and metadata (from YouTube if a match is found).
- pkgver = 3.8.0
- pkgrel = 3
+ pkgver = 3.9.0
+ pkgrel = 1
url = https://github.com/spotDL/spotify-downloader
install = spotdl.install
arch = any
@@ -20,7 +20,7 @@ pkgbase = python-spotdl
depends = python-beautifulsoup4
depends = python-requests
depends = python-unidecode
- source = https://pypi.io/packages/source/s/spotdl/spotdl-3.8.0.tar.gz
- b2sums = 9c46ae90a26fb09b70ac8e611a8962dcf6a579fb1cfc966b15bf067d47cb7677870996ebb746d965b6d0069fbcf272c3f061077c5cf5d7883898b7a636434135
+ source = https://pypi.io/packages/source/s/spotdl/spotdl-3.9.0.tar.gz
+ b2sums = 523b81f907e078dd0edbb699cc3014531870b447e079c4f56f80ed9bc671356d7d36d31524eb4ebbafe2b96fdbd36e1d7b8c7b8b847f54774b94b855e36c2d26
pkgname = python-spotdl
diff --git a/PKGBUILD b/PKGBUILD
index b1f36584192d..84dcfc3b851d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# Contributor: Gordian Edenhofer <gordian.edenhofer[at]yahoo[dot]de>
pkgname=python-spotdl
-pkgver=3.8.0
-pkgrel=3
+pkgver=3.9.0
+pkgrel=1
pkgdesc="Download your Spotify playlists and songs along with album art and metadata (from YouTube if a match is found)."
arch=('any')
@@ -29,7 +29,7 @@ makedepends=('python-setuptools')
install="spotdl.install"
source=("https://pypi.io/packages/source/s/spotdl/spotdl-$pkgver.tar.gz")
-b2sums=('9c46ae90a26fb09b70ac8e611a8962dcf6a579fb1cfc966b15bf067d47cb7677870996ebb746d965b6d0069fbcf272c3f061077c5cf5d7883898b7a636434135')
+b2sums=('523b81f907e078dd0edbb699cc3014531870b447e079c4f56f80ed9bc671356d7d36d31524eb4ebbafe2b96fdbd36e1d7b8c7b8b847f54774b94b855e36c2d26')
build() {
cd spotdl-$pkgver
diff --git a/spotdl.install b/spotdl.install
index d80672bde7c3..f7ddaf797c88 100644
--- a/spotdl.install
+++ b/spotdl.install
@@ -1,12 +1,12 @@
#!/bin/bash
-BPurple='\033[1;35m' # Bold purple
-Cyan='\033[0;36m' # Cyan
-Reset='\033[0m' # Reset
+B='\033[1;36m' # Bold cyan
+C='\033[0;36m' # Cyan
+R='\033[0m \a' # Reset all colors and ring a bell
call_to_action() {
- echo -e "$Cyan"
- echo " +-----------------------------------------------------------------------------------------+"
+ echo -e "$C"
+ echo -e " +-$B=[ python-spotdl ]=$C---------------------------------------------------------------------+"
echo " | Remember, |"
echo " | YouTube Music must be available in your country for spotDL to work. |"
echo " | This is because we use YouTube Music to filter search results. |"
@@ -14,7 +14,7 @@ call_to_action() {
echo " | by visiting \`https://music.youtube.com/\`. |"
echo " | |"
echo " | If your country doesn't support YouTube Music, |"
- echo " | you can try using any vpn or proxychains with tor. |"
+ echo " | you can try using any vpn or torsocks. |"
echo " | |"
echo " | You can, |"
echo " | run this app by executing 'spotdl' on your terminal |"
@@ -24,34 +24,25 @@ call_to_action() {
echo " | report issue about the app at : https://github.com/spotDL/spotify-downloader/issues |"
echo " | - zoorat. |"
echo " +-----------------------------------------------------------------------------------------+"
- echo -e "$Reset"
+ echo -e "$R"
}
after_remove() {
- echo -e "$Cyan"
- echo " +--------------------------------------------------------------------------------+"
+ echo -e "$C"
+ echo -e " +-$B=[ python-spotdl ]=$C------------------------------------------------------------+"
echo " | You should remove all '.spotdl-cache' files. |"
echo " | to find that file run \` tree -fia /mnt /home | grep \".spotdl-cache\" \` |"
echo " | - zoorat. |"
echo " +--------------------------------------------------------------------------------+"
- echo -e "$Reset"
+ echo -e "$R"
}
-# arg 1: the new package version
post_install() {
- echo -e "$BPurple:: done installing 'python-spotdl $1' $Reset"
call_to_action
}
-
-# arg 1: the new package version
-# arg 2: the old package version
post_upgrade() {
- echo -e "$BPurple:: done upgrading python-spotdl from '$2' to '$1' $Reset"
call_to_action
}
-
-# arg 1: the old package version
post_remove() {
- echo -e "$BPurple:: done removing 'python-spotdl $1' $Reset"
after_remove
}