summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsharktamer2019-05-30 00:41:04 +0100
committersharktamer2019-05-30 00:41:04 +0100
commit7096f3bb79d1e958e7e7c33b3320bc4fd4fd28ca (patch)
tree993e5231b2ee06e0bea63a166ad2835854c239a9
downloadaur-7096f3bb79d1e958e7e7c33b3320bc4fd4fd28ca.tar.gz
first sputils aur release
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD18
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c425263ca36b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-sputils
+ pkgdesc = A collection of spotify utilities, designed to be used with other shell utilities.
+ pkgver = 0.1.2
+ pkgrel = 1
+ url = https://github.com/shanedabes/sputils
+ arch = any
+ license = APACHE
+ depends = python
+ depends = python-configargparse
+ depends = python-pyaml
+ depends = python-spotipy
+ source = python-sputils-0.1.2.tar.gz::https://github.com/shanedabes/sputils/archive/v0.1.2.tar.gz
+ sha256sums = 64bf10bbbbefacac15e1ef4d14d5dff655ad9d8f2a97a4b11a5465bbe7a3cb16
+
+pkgname = python-sputils
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..77c5900e34e7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Shane Donohoe <shane@donohoe.cc>
+
+pkgname=python-sputils
+pkgver=0.1.2
+pkgrel=1
+pkgdesc="A collection of spotify utilities, designed to be used with other shell utilities."
+arch=('any')
+url="https://github.com/shanedabes/sputils"
+license=('APACHE')
+depends=('python' 'python-configargparse' 'python-pyaml' 'python-spotipy')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/shanedabes/sputils/archive/v${pkgver}.tar.gz")
+sha256sums=('64bf10bbbbefacac15e1ef4d14d5dff655ad9d8f2a97a4b11a5465bbe7a3cb16')
+
+package() {
+ cd "sputils-${pkgver}"
+ python setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}