summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2017-09-12 00:39:33 +0200
committerhaawda2017-09-12 00:39:33 +0200
commitc43a2c79530ef9509067bcfe35548d5299075b65 (patch)
tree9c75d6cff0034574a3bf16d0faa7c8cd4eb2b4c3
parent3801dbc1bc69e09341320c824cfb52953e2e3d03 (diff)
downloadaur-c43a2c79530ef9509067bcfe35548d5299075b65.tar.gz
Updated version (1.2.0b2.96.gdb170dd45 -> 1.2.0b2.98.g31f80b9ea).
Changelog ========= Refactor for cx_Oracle version 6 (31f80b9ea) Don't use repr() for Column/ColumnClause in warning (4c97ea116) Warn instead of raise for unmapped column that matches on key (db170dd45) Merge "Remove LRU warnings" (ca2c42df6) Remove LRU warnings (e83024d3f) Rename MySQL dml.insert().values to .inserted (70be7312f) - skip oracle tests until we can merge refactor (5ae984b94) - add separate oracle / oracle5 jobs so we can CI on both series for now (2e137b395) Version 1.1.15 placeholder (8a85729dc) - 1.1.14 (47d4d8763) - 1.1.14 placeholder (202048654) Merge "Guard against KeyError in session.merge after check for identity" (e76c012ec) Merge "Check for non-mapped property in synonym" (eabdbd1d3) Merge "Ensure custom ops have consistent typing behavior, boolean support" (abf1296ed) Guard against KeyError in session.merge after check for identity (1e21f9c4f) - add forwards-port versions (af8a81534) Check for non-mapped property in synonym (130f31ca7) Always check that discarded state is the expected one (37c5ed2ed) Ensure custom ops have consistent typing behavior, boolean support (919b8bc4a) Add InternalError for mysqlclient disconnect (65680b234) include a note about the importance of type coerce for custom ops (56845d8cc) Consider merge key with (None, ) as non-persistent (3feea4503) Add SQL Server CI coverage (2efd89d02) - pin on cx_Oracle 6.0.1 for the moment while we wait for either https://github.com/oracle/python-cx_Oracle/issues/75 to be fixed or we can merge a workaround (de73c6d1c) Additional fixes to sane rowcount (c4d6596ba) Add new sane_rowcount_w_returning flag (b9b1e374b) Use text_type, not unicode (d0470e296) Enable native boolean for SQL Server (888f112b7) Merge "Join key_constraints on schema as well for SQL server get_fks" (22396493b) Merge "Ignore SQL Server "heap" indexes" (28e6c79cf) Add preparer to pymssql that disables percent doubling (51c243291) Ignore SQL Server "heap" indexes (3e855cd27) Join key_constraints on schema as well for SQL server get_fks (43447c425) - rename SQL server autocommit issue to 4058 Fixes #4058 (812c08efb) Implement AUTOCOMMIT for pyodbc, pymssql (56950a78d) Generalize autocommit testing (ec4f567f3) Merge "Apply percent sign escaping to literal binds, comments" (4f3423449) Merge "Don't do recovery operations under Empty/AttributeError" (fd6a711f5) Apply percent sign escaping to literal binds, comments (2392ae190) Don't do recovery operations under Empty/AttributeError (f87069a3b) Merge "Allow for multiple FOLLOWING/PRECEDING in a window range" (4baa9041c) Allow for multiple FOLLOWING/PRECEDING in a window range (3a5bbe4cb) Merge "Ensure col is not None when retrieving quick populators" (887fb3eba) - remove 3.4's (e33cff44b) Ensure col is not None when retrieving quick populators (827b495b8) Handle cache key for option that has no strategy (3f9df2b86) - fix typos (d8a80a35a) - modernize the mysql connection timeout docs (2db525614) Deactivate transaction if rollback fails (8b53548b9) - ensure identifier re-use doesn't make this break (41549de96) - allow a separate template database to be used for PG CREATE DATABASE. as nobody will connect to it that would solve the contention issue here (4c3068183) - repair --dbs (df01130bb) - add missing changelog file for #4045 (d4f8b1244) - simplify and see if it still works (fe5eede55) - keep trying to get PG dbs to build (f3f6116c5) - add missing quotes (1d82b4057) - try to get PG database create to be more reliable (ddefe6cf8) - sanitize class names for junit reporting (a61ff195b) Merge branch 'fixtypo' of https://github.com/hsmtkk/sqlalchemy (a2beb234e) - filter out non-oracle URLs (97e455f21) - this test doesn't work in strict mode, not that important (63d47c051) - a few mysql fixes, more to come (64032a35a) - rework oracle de-provisioning to write URLs to the file as well, supporting custom dburi etc. (cc741e1ac) - add some logging for the provisioning (003096620) - dont run sql mode config tests if we aren't on mysql (ed197d4c3) - do ten attempts to create database (a0b584032) Merge "First level repair for cx_Oracle 6.0 test regressions" (062849969) - correct server side cursor assertion for driver names (ecdd922d9) - name these TOX_ so that we can set them unconditionally without them getting used unless we ask for them in the build (9e6393c6b) - rework the unittests README which was very out of date (31491a6ac) First level repair for cx_Oracle 6.0 test regressions (03255a5a0) - convert to spaces (04e4b63c2) Merge "Enable uuid for pg8000" (d173662fe) fix a typo (58fb83c45) Merge "Ensure Oracle index w/ col DESC etc. is reflected" (eb8db2303) Isolate memory tests in forks (2c594da21) Restore original test names (bb9d511e5) Ensure Oracle index w/ col DESC etc. is reflected (1a990ee33) - since we can't isolate the memory tests to run withtout pytest-xdist, add a new tag nomemory so we can at least limit on the build (e331da58a) - try adding the prints back in and re-test (f1fd7f1e0) - take more print statements out, maybe this is not the issue - unblock pytest-xdist now that the upstream issue is fixed, maybe this old version is the issue (3568e508d) Merge branch 'master--typos' of https://github.com/nphilipp/sqlalchemy (eaceeae0f) Enable uuid for pg8000 (c86b95038) Add quoted_name to pg8000 py_types (03560c4b8) - dont print samples, this appears like it may be itself causing the memory leak in conjunction with pytest-xdist (725298ea4) - allow the shrink phase for memusage to go until zeroed, some MySQL-env element is causing memory growth that goes very far before stopping (0a2365464) Enable multi-level selectin polymorphic loading (68879d50f) - modernize orm.reconstructor documentation a bit (4b4f8fbf2) fix "constrast" typos (7765724d5) Allow multiple versions of single backend (de1f8f834) - fix one test for STRICT, which may be turned on by default in mariadb 10.2. more mariadb fixes coming (54cdda032) Pin to pytest<=3.0.7 pytest-xdist<=1.16.0 (4e8b155c7) - 1.0.19 (e6432d78b) - convert to spaces - restore unreleased directories (a1160414b) Merge "Revert cx_Oracle WITH_UNICODE change under > 5.0" (ace88cdd2) Revert cx_Oracle WITH_UNICODE change under > 5.0 (7997d7fdc) - 1.1.13 - 1.0.19 (2ae2c25c5) - 1.2.0b3 prep (546708977)
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD2
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 23de574ed02a..3ffe41db52b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Sep 10 10:35:06 UTC 2017
+# Mon Sep 11 22:39:33 UTC 2017
pkgbase = python-sqlalchemy-git
pkgdesc = Python SQL toolkit and Object Relational Mapper
- pkgver = 1.2.0b2.96.gdb170dd45
+ pkgver = 1.2.0b2.98.g31f80b9ea
pkgrel = 1
url = http://www.sqlalchemy.org
arch = i686
@@ -11,7 +11,7 @@ pkgbase = python-sqlalchemy-git
makedepends = git
makedepends = python-setuptools
depends = python
- provides = python-sqlalchemy=1.2.0b2.96.gdb170dd45
+ provides = python-sqlalchemy=1.2.0b2.98.g31f80b9ea
conflicts = python-sqlalchemy
source = git+https://bitbucket.org/zzzeek/sqlalchemy.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 0477fe383119..cced201db5db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=python-sqlalchemy-git
-pkgver=1.2.0b2.96.gdb170dd45
+pkgver=1.2.0b2.98.g31f80b9ea
pkgrel=1
pkgdesc="Python SQL toolkit and Object Relational Mapper"
arch=('i686' 'x86_64')