summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYohann D'ANELLO2020-11-19 23:15:52 +0100
committerYohann D'ANELLO2020-11-19 23:15:52 +0100
commit055a7e205b805be57b5d37aff8087772c39832d4 (patch)
treedaca67eb71ac75bfbb51db85345a21764f334e2a
downloadaur-055a7e205b805be57b5d37aff8087772c39832d4.tar.gz
First release
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD37
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..570cce602340
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-squirrel-battle
+ pkgdesc = Watch out for squirrel's knives!
+ pkgver = 3.14
+ pkgrel = 2
+ url = https://gitlab.crans.org/ynerant/squirrel-battle
+ arch = any
+ license = GPLv3
+ checkdepends = python-tox
+ makedepends = python-setuptools
+ depends = noto-fonts-emoji
+ source = https://gitlab.crans.org/ynerant/squirrel-battle/-/archive/v3.14/squirrel-battle-v3.14.tar.gz
+ sha256sums = 6090534d598c0b3a8f5acdb553c12908ba8107d62d08e17747d1dbb397bddef0
+
+pkgname = python-squirrel-battle
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..38e4b81a476b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src/
+pkg/
+squirrel-battle/
+*.zst
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cce1b2750b5c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Yohann D'ANELLO <ynerant@crans.org>
+
+pkgbase=squirrel-battle
+pkgname=python-squirrel-battle
+pkgver=3.14
+pkgrel=2
+pkgdesc="Watch out for squirrel's knives!"
+arch=('any')
+url="https://gitlab.crans.org/ynerant/squirrel-battle"
+license=('GPLv3')
+depends=('python')
+makedepends=('python-setuptools')
+depends=('noto-fonts-emoji')
+checkdepends=('python-tox')
+source=("https://gitlab.crans.org/ynerant/squirrel-battle/-/archive/v3.14/$pkgbase-v$pkgver.tar.gz")
+sha256sums=("6090534d598c0b3a8f5acdb553c12908ba8107d62d08e17747d1dbb397bddef0")
+
+build() {
+ cd $pkgbase-v$pkgver
+ python setup.py build
+}
+
+check() {
+ cd $pkgbase-v$pkgver
+ tox -e py3
+ tox -e linters
+}
+
+package() {
+ cd $pkgbase-v$pkgver
+ python setup.py install --skip-build \
+ --optimize=1 \
+ --root="${pkgdir}"
+ install -vDm 644 README.md \
+ -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -vDm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}