summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Höffken2023-09-26 11:27:19 +0200
committerFelix Höffken2023-10-16 21:02:46 +0200
commit1c22a5cffc78873e33f1d19c55e6448554db05e4 (patch)
treeb7747a9a972eedfbc6bdc34fabee4de7b5953433
parent7ecebd292bd32f79f705d098049ee0e8ce0800b8 (diff)
downloadaur-python-srp.tar.gz
Move makedepends to depends and clean up
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eeea4ee115ad..7ad34047cb76 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = python-srp
pkgdesc = Python implementation of the Secure Remote Password protocol (SRP)
pkgver = 1.0.19
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/cocagne/pysrp
arch = any
license = MIT
- makedepends = python
- makedepends = python-six
+ depends = python
+ depends = python-six
+ depends = openssl
source = https://github.com/cocagne/pysrp/archive/1.0.19.tar.gz
sha256sums = 57dd009ed4d739fa4bd7403fb014c0113621e5631953396221749ed53a9dd4a8
pkgname = python-srp
- depends = python
- depends = openssl
diff --git a/PKGBUILD b/PKGBUILD
index 6f17ba3f7072..efe777340193 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,12 +5,12 @@ _srcname=srp
pkgname="python-$_srcname"
pkgbase=python-srp
pkgver=1.0.19
-pkgrel=2
+pkgrel=3
pkgdesc='Python implementation of the Secure Remote Password protocol (SRP)'
arch=('any')
url="https://github.com/cocagne/py$_srcname"
license=('MIT')
-makedepends=('python' 'python-six' )
+depends=('python' 'python-six' 'openssl' )
source=("$url/archive/$pkgver.tar.gz")
sha256sums=('57dd009ed4d739fa4bd7403fb014c0113621e5631953396221749ed53a9dd4a8')
@@ -24,9 +24,7 @@ check() {
python srp/test_srp.py
}
-package_python-srp() {
- depends=('python' 'openssl')
-
+package() {
cd "$srcdir/py$_srcname-$pkgver"
python setup.py install --skip-build --root="$pkgdir" --optimize=1
install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"