summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJuraj Fiala2016-04-07 15:36:57 +0200
committerJuraj Fiala2016-04-07 15:36:57 +0200
commitf2515ad1ba4cbf4164f99497bd6999816cc4a515 (patch)
treea4014a12a70b63943e84ffb12d593fb66b63f822
downloadaur-f2515ad1ba4cbf4164f99497bd6999816cc4a515.tar.gz
Initial commit.
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD20
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b87931c9e3ae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Thu Apr 7 13:36:57 UTC 2016
+pkgbase = python2-srp
+ pkgdesc = Python implementation of the Secure Remote Password protocol (SRP).
+ pkgver = 1.0.5
+ pkgrel = 1
+ url = https://github.com/cocagne/pysrp
+ arch = any
+ license = MIT
+ depends = python2
+ source = https://pypi.python.org/packages/source/s/srp/srp-1.0.5.tar.gz
+ sha256sums = 9ba792f7ec2681b90d9ea70abeb2ffc153a11ae53aa114fcb1bb296eba6a75fe
+
+pkgname = python2-srp
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..44d319eb49a6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!PKGBUILD
+!*.install
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..73eaa41c1f7e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Juraj Fiala <doctorjellyface at riseup dot net
+_srcname=srp
+pkgname=python2-$_srcname
+pkgver=1.0.5
+pkgrel=1
+pkgdesc='Python implementation of the Secure Remote Password protocol (SRP).'
+arch=('any')
+url="https://github.com/cocagne/py$_srcname"
+license=('MIT')
+depends=('python2')
+source=("https://pypi.python.org/packages/source/s/$_srcname/$_srcname-$pkgver.tar.gz")
+sha256sums=('9ba792f7ec2681b90d9ea70abeb2ffc153a11ae53aa114fcb1bb296eba6a75fe')
+
+package() {
+ cd "$srcdir/$_srcname-$pkgver"
+ python2 setup.py install --root="$pkgdir" --optimize=1
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: