summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2020-12-02 12:49:24 -0500
committerGuillaume Horel2020-12-02 12:49:24 -0500
commit6246eb9d5772f7b126a10d9c0702fb5334a1bab3 (patch)
tree7ba0a12c0c02ad797f9c8c9daacd00acba75eecf
parent8a85c8139d67d6d62f9e13bc6e1191e4937f9a05 (diff)
downloadaur-6246eb9d5772f7b126a10d9c0702fb5334a1bab3.tar.gz
bump to 0.23.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 14e82d025fec..a0bbbd084398 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-ssh2
pkgdesc = Python bindings for libssh2
- pkgver = 0.18.0
+ pkgver = 0.23.0
pkgrel = 1
url = https://github.com/ParallelSSH/ssh2-python/
arch = x86_64
@@ -10,8 +10,8 @@ pkgbase = python-ssh2
makedepends = cython
depends = python
depends = libssh2
- source = https://github.com/ParallelSSH/ssh2-python/archive/0.18.0.tar.gz
- sha256sums = 50e4168a911cd2a09ee802a6a301297907de64a5ecce36a1cbdb3a74d6563000
+ source = https://github.com/ParallelSSH/ssh2-python/archive/0.23.0.tar.gz
+ sha256sums = 70ff84e6ce37df877ce239109b713fb0f5b26de6309c72da5fa41723863ab14b
pkgname = python-ssh2
diff --git a/PKGBUILD b/PKGBUILD
index 17f7e6401fd7..628c0161b184 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
pkgname='python-ssh2'
_pkgname='ssh2-python'
-pkgver='0.18.0'
+pkgver='0.23.0'
pkgrel=1
pkgdesc="Python bindings for libssh2"
url="https://github.com/ParallelSSH/ssh2-python/"
@@ -11,20 +11,20 @@ checkdepends=('python-pytest')
license=('GPL')
arch=('x86_64')
source=("https://github.com/ParallelSSH/$_pkgname/archive/$pkgver.tar.gz")
-sha256sums=('50e4168a911cd2a09ee802a6a301297907de64a5ecce36a1cbdb3a74d6563000')
+sha256sums=('70ff84e6ce37df877ce239109b713fb0f5b26de6309c72da5fa41723863ab14b')
build() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd "${_pkgname}-${pkgver}"
SYSTEM_LIBSSH2=1 python setup.py build_ext
}
package() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd "${_pkgname}-${pkgver}"
SYSTEM_LIBSSH2=1 python setup.py install --root="${pkgdir}" --optimize=1
}
-#check() {
- #cd "${srcdir}/${pkgname}-${pkgver}"
- #python setup.py build_ext --inplace
- #PYTHONPATH=. py.test
-#}
+check() {
+ cd "${_pkgname}-${pkgver}"
+ SYSTEM_LIBSSH2=1 python setup.py build_ext --inplace
+ pytest tests
+}