summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2019-04-11 16:22:07 -0400
committerGuillaume Horel2019-04-11 16:22:07 -0400
commit8a85c8139d67d6d62f9e13bc6e1191e4937f9a05 (patch)
treebca700a71b4d7ff1ca1e39aace2a3e745825ea6a
downloadaur-8a85c8139d67d6d62f9e13bc6e1191e4937f9a05.tar.gz
original import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD30
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..14e82d025fec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-ssh2
+ pkgdesc = Python bindings for libssh2
+ pkgver = 0.18.0
+ pkgrel = 1
+ url = https://github.com/ParallelSSH/ssh2-python/
+ arch = x86_64
+ license = GPL
+ checkdepends = python-pytest
+ makedepends = python-setuptools
+ makedepends = cython
+ depends = python
+ depends = libssh2
+ source = https://github.com/ParallelSSH/ssh2-python/archive/0.18.0.tar.gz
+ sha256sums = 50e4168a911cd2a09ee802a6a301297907de64a5ecce36a1cbdb3a74d6563000
+
+pkgname = python-ssh2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..17f7e6401fd7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
+pkgname='python-ssh2'
+_pkgname='ssh2-python'
+pkgver='0.18.0'
+pkgrel=1
+pkgdesc="Python bindings for libssh2"
+url="https://github.com/ParallelSSH/ssh2-python/"
+depends=('python' 'libssh2')
+makedepends=('python-setuptools' 'cython')
+checkdepends=('python-pytest')
+license=('GPL')
+arch=('x86_64')
+source=("https://github.com/ParallelSSH/$_pkgname/archive/$pkgver.tar.gz")
+sha256sums=('50e4168a911cd2a09ee802a6a301297907de64a5ecce36a1cbdb3a74d6563000')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ SYSTEM_LIBSSH2=1 python setup.py build_ext
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ SYSTEM_LIBSSH2=1 python setup.py install --root="${pkgdir}" --optimize=1
+}
+
+#check() {
+ #cd "${srcdir}/${pkgname}-${pkgver}"
+ #python setup.py build_ext --inplace
+ #PYTHONPATH=. py.test
+#}