summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2021-12-13 16:48:24 -0500
committerGuillaume Horel2021-12-13 16:48:31 -0500
commitcc8d5ec4058e13f6ebf31b24a96f1d07a4f40ac2 (patch)
tree1b0332970891790f06542fa44b25df4ddb8efac2
parent72bea2571c31cde915a317194856530b776936fa (diff)
downloadaur-cc8d5ec4058e13f6ebf31b24a96f1d07a4f40ac2.tar.gz
bump to 0.27.0
-rw-r--r--PKGBUILD12
-rw-r--r--fix-tests.patch32
2 files changed, 20 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index eb1450768b08..895de9617876 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
pkgname='python-ssh2'
_pkgname='ssh2-python'
-pkgver=0.26.0
+pkgver=0.27.0
pkgrel=1
pkgdesc="Python bindings for libssh2"
url="https://github.com/ParallelSSH/ssh2-python/"
@@ -12,22 +12,22 @@ license=('GPL')
arch=('x86_64')
source=("$pkgname-$pkgver.tar.gz::https://github.com/ParallelSSH/$_pkgname/archive/$pkgver.tar.gz"
"fix-tests.patch")
-sha256sums=('38912993a9d63f8ec6f137d04c8eff1c840bb4b4801260a5b686e50ab57c86e7'
- '49c6c5d2021db7a7ae5d81b7f34abd16bef06e8112d72b17a86eb8760d339f57')
+sha256sums=('6da1c0331aef63f4a4c6cd27e5cb06bab7dcf311d887e918c6d6d058debb18fe'
+ 'b328ec97238be0fab6171108666c18f7818de2dea247857851b2356303d65e19')
prepare() {
cd "${_pkgname}-${pkgver}"
- patch -p0 -i ../fix-tests.patch
+ patch -p1 -i ../fix-tests.patch
}
build() {
cd "${_pkgname}-${pkgver}"
- SYSTEM_LIBSSH2=1 python setup.py build_ext
+ SYSTEM_LIBSSH2=1 python setup.py build
}
package() {
cd "${_pkgname}-${pkgver}"
- SYSTEM_LIBSSH2=1 python setup.py install --root="${pkgdir}" --optimize=1
+ SYSTEM_LIBSSH2=1 python setup.py install --skip-build --root="${pkgdir}" --optimize=1
}
check() {
diff --git a/fix-tests.patch b/fix-tests.patch
index 1bbf9499bcf2..6b2e3e2011d3 100644
--- a/fix-tests.patch
+++ b/fix-tests.patch
@@ -1,18 +1,14 @@
---- tests/test_sftp.py 2021-04-10 21:23:36.390635351 -0400
-+++ tests/test_sftp.py 2021-04-10 21:22:43.131928927 -0400
-@@ -256,7 +256,6 @@
- sftp = self.session.sftp_init()
- vfs = sftp.statvfs('.')
- self.assertTrue(vfs is not None)
-- self.assertTrue(vfs.f_files > 0)
- self.assertTrue(vfs.f_bsize > 0)
- self.assertTrue(vfs.f_namemax > 0)
-
-@@ -272,7 +271,6 @@
- with sftp.open(remote_filename, 0, 0) as fh:
- vfs = fh.fstatvfs()
- self.assertTrue(vfs is not None)
-- self.assertTrue(vfs.f_files > 0)
- self.assertTrue(vfs.f_bsize > 0)
- self.assertTrue(vfs.f_namemax > 0)
- except Exception:
+diff -urN ssh2-python-0.27.0-orig/tests/embedded_server/sshd_config.tmpl ssh2-python-0.27.0/tests/embedded_server/sshd_config.tmpl
+--- ssh2-python-0.27.0-orig/tests/embedded_server/sshd_config.tmpl 2021-12-13 16:33:07.725557322 -0500
++++ ssh2-python-0.27.0/tests/embedded_server/sshd_config.tmpl 2021-12-13 16:33:39.578913619 -0500
+@@ -1,8 +2,9 @@
+ Protocol 2
+-UsePAM yes
+ HostbasedAuthentication no
+ IgnoreUserKnownHosts yes
+ ListenAddress 127.0.0.1
++HostKeyAlgorithms +ssh-rsa
++PubkeyAcceptedAlgorithms +ssh-rsa
+
+ AcceptEnv LANG LC_*
+ Subsystem sftp internal-sftp