diff options
author | Benoît Allard | 2023-10-08 10:53:12 +0200 |
---|---|---|
committer | Benoît Allard | 2023-10-08 10:53:12 +0200 |
commit | f6332ab64ae4fdf35a63e9c56d85d6eb9dcb245c (patch) | |
tree | 7f56b946bd4dd780d818d3260f90ce97211e3896 | |
parent | 536914bebbc2b366f6a26d99371e05e7a5bc2a9a (diff) | |
download | aur-f6332ab64ae4fdf35a63e9c56d85d6eb9dcb245c.tar.gz |
2.1.0
-rw-r--r-- | .SRCINFO | 13 | ||||
-rw-r--r-- | PKGBUILD | 20 |
2 files changed, 23 insertions, 10 deletions
@@ -1,23 +1,26 @@ pkgbase = python-stable-baselines3 pkgdesc = A set of reliable implementations of reinforcement learning algorithms in PyTorch - pkgver = 1.5.0 + pkgver = 2.1.0 pkgrel = 1 url = https://github.com/DLR-RM/stable-baselines3 arch = any license = MIT depends = python - depends = python-gym + depends = python-gymnasium depends = python-numpy depends = python-pytorch depends = python-cloudpickle depends = python-pandas depends = python-matplotlib optdepends = python-opencv: For render - optdepends = python-ale-py: For atari games + optdepends = python-pygame: For render + optdepends = python-shimmy: For atari games optdepends = python-pillow: For atari games optdepends = tensorboard: Tensorboard support optdepends = python-psutil: Checking memory taken by replay buffer - source = python-stable-baselines3-1.5.0.tar.gz::https://github.com/DLR-RM/stable-baselines3/archive/v1.5.0.tar.gz - md5sums = 9ed6a2042ab0b7a7f216c1d62e0626d2 + optdepends = python-tqdm: For progress bar callback + optdepends = python-rich: For progress bar callback + source = python-stable-baselines3-2.1.0.tar.gz::https://github.com/DLR-RM/stable-baselines3/archive/v2.1.0.tar.gz + sha256sums = 9d62ac964579194b89f0d876ee5dbd59589717c70531eb73a6ce62aa06caa6c5 pkgname = python-stable-baselines3 @@ -1,20 +1,29 @@ # Maintainer: Benoît Allard <benoit.allard@gmx.de> pkgname=python-stable-baselines3 -pkgver=1.5.0 +pkgver=2.1.0 pkgrel=1 pkgdesc="A set of reliable implementations of reinforcement learning algorithms in PyTorch" arch=('any') url="https://github.com/DLR-RM/stable-baselines3" license=('MIT') -depends=("python" "python-gym" "python-numpy" "python-pytorch" "python-cloudpickle" "python-pandas" "python-matplotlib") +depends=("python" + "python-gymnasium" + "python-numpy" + "python-pytorch" + "python-cloudpickle" + "python-pandas" + "python-matplotlib") optdepends=('python-opencv: For render' - 'python-ale-py: For atari games' + 'python-pygame: For render' + 'python-shimmy: For atari games' 'python-pillow: For atari games' 'tensorboard: Tensorboard support' - 'python-psutil: Checking memory taken by replay buffer') + 'python-psutil: Checking memory taken by replay buffer' + 'python-tqdm: For progress bar callback' + 'python-rich: For progress bar callback') _name=${pkgname#python-} source=("$pkgname-$pkgver.tar.gz::https://github.com/DLR-RM/$_name/archive/v$pkgver.tar.gz") -md5sums=('9ed6a2042ab0b7a7f216c1d62e0626d2') +sha256sums=('9d62ac964579194b89f0d876ee5dbd59589717c70531eb73a6ce62aa06caa6c5') build() { cd $_name-$pkgver @@ -26,3 +35,4 @@ package() { cd $_name-$pkgver python setup.py install --root="$pkgdir" --optimize=1 --skip-build } + |